WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#14357 closed enhancement (duplicate)

get_page_by_path() and get_page_by_title() lack caching

Reported by: Viper007Bond Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Performance Keywords:
Focuses: Cc:

Description

get_page_by_path() and get_page_by_title() always hit the database. We should add caching and caching invalidation for these two functions.

Change History (7)

#2 @scribu
9 years ago

Similar: #13170

#3 @shidouhikari
9 years ago

  • Cc shidouhikari added

cache optimization is always important, let database rest a bit!

#4 @Viper007Bond
9 years ago

Can anyone think of a good way to do this with existing caches? Or should these functions just make their own cache groups?

#5 @nacin
9 years ago

  • Milestone changed from Awaiting Review to Future Release

#6 @johnbillion
9 years ago

get_page_by_path() was patched in r16206, get_page_by_title() needs the same treatment.

#7 @Viper007Bond
9 years ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a dupe of #11373, opened a new ticket for just get_page_by_title(): #15805

Note: See TracTickets for help on using tickets.