WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#14374 closed feature request (duplicate)

Concatenate frontend resources

Reported by: markjaquith Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords: google frontend concatenation
Focuses: Cc:

Description

This comes as a suggestion from Google, who wants to help publishing platforms deliver content faster.

Many WordPress sites suffer from too many separate CSS files and JS files. They could reduce HTTP requests and improve performance by concatenating these together. If we do this in core, we can include plugin resources as well as theme resources.

Change History (4)

comment:1 follow-up: @Denis-de-Bernardy5 years ago

There's a dupe of this somewhere. It relates to extending the WP scripts and styles classes, or depends, to make it core.

Btw, it's not too hard todo with a plugin.

comment:2 @nacin4 years ago

  • Milestone changed from Awaiting Review to Future Release

comment:3 in reply to: ↑ 1 @johnbillion3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to Denis-de-Bernardy:

There's a dupe of this somewhere.

#3372

comment:4 @SergeyBiryukov3 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.