WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#14388 closed defect (bug) (invalid)

upload image with same name do not replace the older one

Reported by: maurizio04 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upload Keywords:
Focuses: Cc:

Description

I uploaded an image on web site.
after i edited the same image, delted it from the galley, and uploaded the new one.
On the post there was still the old image.

I had to change the file name to get the new, changing description in the gallery was useless.
it seems the original file is not really deleted and the next upload is not overwriting it.

The bug if I remember well is old, same problem 1 year ago...
-m

Change History (5)

#1 @dd32
9 years ago

  • Component changed from Gallery to Upload
  • Keywords reporter-feedback added; image upload removed

When you uploaded the new version of the image, Was it renamed to another name so as not to conflict with an existing file? ie. Was it changed from filename.jpg to filename1.jpg? or something else?

Are the files being deleted from your uploads folder? If not, Are the files still visible on the media management pages?

#2 @maurizio04
9 years ago

No, i deleted the file in the galley and upload a file with same name but different content.
the older one shwed up.
i had to rename the new upload to make it work.

i haven't checked if the delete from gallery actually deleted the file but i guess no, if it was still usable later.

it seems that the old file is not deleted and the new upload fail with no warning leaving the original file in place.

if necessary i can repeat the operation checking on what happen on the host folder.

-m

#3 @maurizio04
9 years ago

--more testing.
it seems a "caching" problem of the flash gadget that handle gallery and image insert.

when i delete the image it gets deleted.
when uploading image with same name the image on upload folder on site is CORRECT but preview in dashboard still has old content, same if choosing gallery content.

on the post the image contents remain the old or gets updated it seems depending what operation is carried out.

in this test for the first time i got the image updated at one point, on last try it was never updated but , NOW, knowing that the file on server is correct if I had saved and published and returned editing the correct image would have been on screen, i presume.

#4 follow-up: @maurizio04
9 years ago

--ok summary......
delete image from gallery on server ok
upload new image same name different content ok

flash gadget is not refreshing image displayed if it has the same name of the last deleted

-m

#5 in reply to: ↑ 4 @azaozz
9 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 3.0 deleted

Replying to maurizio04:

So this is a caching problem caused by using new image with the same name. That would affect any website (even a "static" one) and is dependent on server settings. Given that you don't want to change the HTML (post content) but only to replace the image, I don't see a way around it. The new image would show a bit later or if you force-refresh the page.

Note: See TracTickets for help on using tickets.