WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#14434 closed defect (bug) (worksforme)

WP Admin - Posts - Posts not appearing if uncategorized

Reported by: christopherross Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

Over the past few weeks I've been shuffling a lot of content around on my site and today I realized I had 25+ posts on the site which did not appear in my WP-admin post listings.

What all of these posts had in common was that they had been added more than six months ago (could have been longer) and certainly several versions ago.

All had their parent category deleted without being reassigned to a new category over the past year.

They still appeared on the site as normal.

They appeared in the WP admin > Post > Search results if content was searched for

The appeared in the list of the WP admin > Post > Search results with the category "Uncategorized" in Italics but did not appear in the normal WP admin > Post list at all.

Change History (2)

comment:1 @nacin5 years ago

  • Keywords reporter-feedback added

I don't think these should be hidden, however. Can you provide more details on the post objects that were suppressed? Also, disable plugins and switch to the default theme...

comment:2 @dd325 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I cant reproduce this.. Any posts with Zero terms attached to it (Did a DB delete for all relationships for that post), results in the post appearing with "Uncategorized" as the category (albeit, without a link on it).

the post appears in the correct location in the order of the posts, first page or 3rd page, etc.

Note: See TracTickets for help on using tickets.