WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 4 years ago

#14445 closed enhancement (fixed)

dbdelta do not handel FULLTEXT KEY correctly and generate MySQL errors

Reported by: edirect24 Owned by: pento
Milestone: 4.4 Priority: normal
Severity: normal Version: 3.0
Component: Database Keywords: has-patch
Focuses: Cc:

Description

When using dbdelta during the update of a plugin that a Fulltext index use, dbdelta generate a MYSQL error due to duplicate index.

This is due to the array_search return always false.

I attached a posible solution to address this issue. I added a key named 'index_type' to the $index_ary. This way, when 'index_type' == fulltext, I add to $index_string "FULLTEXT".

Attachments (2)

upgrade.php.patch (1.1 KB) - added by edirect24 10 years ago.
Proposed patch for wp-admin/includes/upgrade.php
14445.diff (942 bytes) - added by mdawaffe 9 years ago.

Download all attachments as: .zip

Change History (9)

@edirect24
10 years ago

Proposed patch for wp-admin/includes/upgrade.php

#1 @mdawaffe
9 years ago

  • Component changed from General to Database
  • Keywords tested added; dev-feedback removed
  • Milestone changed from Awaiting Review to Future Release

Confirmed.

Patch works for me. Refreshed.

@mdawaffe
9 years ago

#2 @chriscct7
5 years ago

  • Keywords tested removed
  • Resolution set to invalid
  • Status changed from new to closed

DbDelta was removed before this patch could be merged.

#3 @ocean90
5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#4 @chriscct7
5 years ago

It does indeed. I'm sorry about that. Not sure what I was thinking.

#5 @chriscct7
4 years ago

  • Owner set to pento
  • Severity changed from minor to normal
  • Status changed from reopened to reviewing

@pento what do you think about this?

#6 @pento
4 years ago

  • Milestone changed from Future Release to 4.4
  • Status changed from reviewing to accepted
  • Type changed from defect (bug) to enhancement

#7 @pento
4 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 35487:

Upgrades: Add support for FULLTEXT indexes to dbDelta().

Props edirect24, mdawaffe, pento.

Fixes #14445.

Note: See TracTickets for help on using tickets.