WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#14472 closed defect (bug) (invalid)

get_categories - child_of

Reported by: christian_gnoth Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Taxonomy Keywords:
Focuses: Cc:

Description

I want delete all categories which are childs_of a parent_categorie - three level - parent_cat --> sub_cat --> childs_cats

the childs_cata can be empty.

if I use the parameter child_of - I do not get those empty cats!!!

the possibility should be there to get them too.

it is for me important to get them deleted to have an actual view of existing categories - which are generated out from an external source.

Change History (13)

comment:1 @nacin5 years ago

Duplicate of #14446?

comment:2 @christian_gnoth5 years ago

  • Severity changed from critical to blocker

no it is not duplicate to this !!!

I can generate a complete list of categories and check for each if they are childs of the parent, but that function should work and give those cats as result.

comment:3 @nacin5 years ago

  • Severity changed from blocker to normal

It looks like a duplicate. The other ticket is reporting that when child_of is used, then hide_empty has no effect. So even if you set hide_empty to false, as you should here, it won't work.

Please don't overinflate severity.

comment:4 @christian_gnoth5 years ago

  • Severity changed from normal to blocker

its not duplicate as I do not want exclude cats, but I want all child_of a cat - it is a similiar problem, but the get_terms function has to be changed on different places!!!

comment:5 @christian_gnoth5 years ago

  • Severity changed from blocker to major

found a work around

comment:7 @christian_gnoth5 years ago

what is the status of the problem???

comment:8 @nacin4 years ago

I don't know what your problem is.

comment:9 @christian_gnoth4 years ago

  • Severity changed from major to normal

the other ticket is a similiar problem, but not the same as the get_terms functions has to be changed on other points. infact that are two problems.

both have to be solved.

comment:10 @nacin4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Re-open if you provide a patch. Otherwise, this ticket is done.

comment:11 @christian_gnoth4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

now you have closed most of my tickets, but actually this one is a bug.

I can take the time and try to find out how to change the code, but then please keep it open so that I have it on my ticket page.

comment:12 @christian_gnoth4 years ago

same with 14471 - it is a bug - out of my view.

comment:13 @christian_gnoth4 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

it is working - I close this ticket

Note: See TracTickets for help on using tickets.