WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#14483 closed defect (bug) (invalid)

Last updated author name is not refreshed in 2.9.2

Reported by: misty9 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: General Keywords: close
Focuses: Cc:

Description

I've posted the question at Wordpress forum, but there have been no replies.

Two of the users on my blog both have administrator's privileges. A page is created by USER1, after USER2 had edited and saved the changes, the Last Update field still shows USER1 has last updated the page. Is it by design or something you can help me tweak it? Thanks.

Change History (14)

#1 @scribu
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

See #12736.

#2 @scribu
8 years ago

Oups, I meant #12763.

#3 @misty9
8 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Reopening the bug as per suggestion of mrmist made in bug http://core.trac.wordpress.org/ticket/12763#comment:23.

"I'm unable to reproduce this new issue. At the very least I'd suggest that this be taken up as a new ticket, because the originally posted issue is fixed. More likely this belongs in the forums, it's probably a plugin issue."

I have entered a question on the forum, but no one seems to have the answer. http://wordpress.org/support/topic/why-last-updated-author-name-is-not-refreshed? replies=3#post-1625097.

Issue: The Last Updated remains the creator of the page rather than the updator Note: The existing page was created a couple years ago by Admin01 and it's been updated by Admin02.

Here are the steps to reproduce the issue that I have encountered in WP 2.9.2 and 3.0.1

  1. Create a PAGE (not a post) named TEST as Admin01 2. Edit the PAGE TEST as Admin02 and press the Update button to save the PAGE 3. Refresh the TEST URL and it still says Admin01 has updated the PAGE:

"Last updated: August 2, 2010 by Admin01"

Let me know if you need anything else from me. Thanks.

#4 follow-up: @mrmist
8 years ago

Potentially some kind of browser cache issue? What happens if you view in another browser?

#5 follow-up: @nacin
8 years ago

Followed your steps to reproduce and it works for me. the _edit_last and _edit_lock postmeta values were updated to accurately reflect the state of the page at any given time.

#6 in reply to: ↑ 4 @misty9
8 years ago

Replying to mrmist:

Potentially some kind of browser cache issue? What happens if you view in another browser?

I have tested it with Chrome and Firfox which both show the creator of the PAGE instead of the updater.

#7 in reply to: ↑ 5 @misty9
8 years ago

Replying to nacin:

Followed your steps to reproduce and it works for me. the _edit_last and _edit_lock postmeta values were updated to accurately reflect the state of the page at any given time.

Thanks. Hmmm, I supposed that you did create A PAGE rather than a POST? I wonder if there are any settings can be tweaked in Wordpress Site Admin.

#8 @misty9
8 years ago

I am not sure if the following information is relevant to my issue. Here is the line that I've found in my PAGE.php:

<span class=""><?php post_updated('F j, Y'); ?> by <?php the_author() ?></span>&nbsp;

Where the post_updated is a plugin that I have on my blog. http://guff.szub.net/2005/02/22/post-updated/.

Thanks.

#9 @mrmist
8 years ago

  • Keywords close added

Ahh, I thought you were referring to the actual status line shown in the editor, I believe you need to use get_the_modified_author() if you want to show the last editor in your theme.

On that basis, recommend closing this.

#10 @misty9
8 years ago

Okay. Thanks Mr. Mist.

Can you please show me the actual syntax for using get_the_modified_author()? I will close this ticket as soon as I test my page. thanks.

#11 @misty9
8 years ago

Fyi, I have upgraded to WP 3.0.1 already.

#12 @misty9
8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

I have used the_modified_author() that works now. Thank you so much for your help.

#13 @scribu
8 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#14 @scribu
8 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.