WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 months ago

Last modified 4 months ago

#14491 closed defect (bug) (duplicate)

Quotation mark broken after ciphers

Reported by: Dannny Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Formatting Keywords: wptexturize
Focuses: Cc:

Description

As a default bug in Wordpress, quotation marks like the following ones don't work if they are positioned after ciphers/digits:

′
’

The problem is that after the digits the HTML special chars are actually not like the ones posted above. After ciphers/digits, the following source code shows us:

“2010′
’2011′

Here's the solution like it should be in the source code:

“2010”
’2011’

Change History (10)

comment:1 Dannny4 years ago

  • Summary changed from Quotation mark after ciphers to Quotation mark broken after ciphers

comment:2 westi4 years ago

Related #4539 - Maybe this is a duplicate of that.

Are you putting the entities in directly or are they being converted from the real characters?

comment:3 nacin4 years ago

  • Keywords wptexturize added; quotation mark removed

comment:4 nacin4 years ago

  • Component changed from General to Formatting
  • Milestone changed from Awaiting Review to Future Release

comment:5 norbertm4 years ago

Do you mean it is broken when you type in '2010' and "2011"?

comment:6 norbertm4 years ago

Able to reproduce. Fixing.

comment:7 norbertm4 years ago

Submitted fix & tests to the growing patch in #4539.

comment:8 miqrogroove4 months ago

Could someone help me improve the description for this ticket? The original post is too vague.

comment:9 miqrogroove4 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8775.

Feel free to follow up, but otherwise let's call it a duplicate.

comment:10 DrewAPicture4 months ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.