WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#14507 closed defect (bug) (worksforme)

error when inserting an image from the media library into a post when the image has parenthesis in the title, alt or description

Reported by: rodneyb Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

When you are making a post, if you add an image to the post, the image cannot have parenthesis in the title, caption, alt or description without giving a code 500 Internal Server error.

If you remove the parenthesis, the error goes away.

I also tested this on wordpress.com and the same error seems to happen (except I just get a blank page)

Change History (4)

comment:1 in reply to: ↑ description rodneyb4 years ago

I just tested this on a wordpress 3.0 install and using parenthesis in those same areas of an image in a post seems to work just fine.

comment:2 mdawaffe3 years ago

  • Keywords reporter-feedback added

I cannot reproduce this bug. Can you provide specific steps?

comment:3 designsimply3 years ago

I tested with the following example code on WordPress.com and WordPress r17316 and couldn't reproduce.

[caption id="" align="alignnone" width="176" caption="this is (the) caption"]<a href="http://s.wordpress.org/about/images/wordpress-logo-notext-bg.png"><img title="this is (the) title" src="http://s.wordpress.org/about/images/wordpress-logo-notext-bg.png" alt="this is (the) alt text" width="176" height="145" /></a>[/caption]

comment:4 nacin3 years ago

  • Keywords post image gallery escape removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

You can re-open this with steps to reproduce.

Note: See TracTickets for help on using tickets.