WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#14535 closed defect (bug) (duplicate)

TinyMCE inserts font-size and line-height spans on Google Chrome when adding lists via the visual editor

Reported by: duckpuppy Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. Create a new post. Make sure that you are using the default TwentyTen theme (will explain why at the end).
  2. Click the "Unordered List" button. Add one or more list items
  3. Click the "Unordered List" button again. Look at the code in HTML view.

A sample of the result is below:

Testing
<ul>
	<li>This is a test</li>
</ul>
<span style="font-size: medium;"><span style="line-height: 24px;">
</span></span>

The reason using the default theme is important is because then you can be sure that the new editor styles feature is being used. In the 2010functions.php file, if I comment out the call to add_editor_style() in the twentyten_setup() function, then the problem goes away.

Change History (4)

comment:1 duckpuppy4 years ago

This is similar to Ticket #14218, maybe the root cause is the same.

comment:2 duckpuppy4 years ago

  • Cc paikens@… added

comment:3 duckpuppy4 years ago

  • Component changed from Editor to TinyMCE

comment:4 nacin4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Consolidating into #14218.

Note: See TracTickets for help on using tickets.