WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#14540 closed enhancement (wontfix)

Should be able to reply to a comment which is in the maximal possible nest

Reported by: mark-k Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords: ux-feedback
Focuses: Cc:

Description

When comments reach the maximal nesting, it is confusing for users which got used to having the ability to "reply to" as to how can they reply to those comments.
My suggestion is to keep the "reply to", but instead of creating a new level, to just append the new comment after the latest comment at the same level.

Change History (29)

comment:1 markmcwilliams4 years ago

  • Component changed from General to Comments

I can see some logic behind that, I'm sure there have been a few other Trac Tickets mention this too (don't have any #'s to hand though!)

comment:2 follow-ups: jane4 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

That would completely undermine the meaning of the reply to link. The choice on allowing replies is up to the site owner. If they've state they don't want replies nested past a certain level, it would be completely irresponsible for us to make core 'override' that setting by still showing a reply link. People are smart enough to see that there is no reply link on one message but that there is one a level up, and just use that.

comment:3 in reply to: ↑ 2 mark-k4 years ago

Replying to jane:

That would completely undermine the meaning of the reply to link. The choice on allowing replies is up to the site owner. If they've state they don't want replies nested past a certain level, it would be completely irresponsible for us to make core 'override' that setting by still showing a reply link. People are smart enough to see that there is no reply link on one message but that there is one a level up, and just use that.

Jane, after there are several comments at the maximal nest it becomes a PITA to find the original comment, and reply to it, and while all of us might understand what is going behind the scene and act in appropriate way, for the common commenter it is totally not obvious.
If the semantics should be different than a "reply to", thats ok, but it will be nice if this problem will get some kind of solution.

comment:4 follow-up: jane4 years ago

@mark-k: Yes, it can be a PITA, but it the blog owner's choice, not ours. We should not try to make core override the blog owner's choice. It's their site; WP is just the underlying platform.

comment:5 in reply to: ↑ 2 filosofo4 years ago

Replying to jane:

That would completely undermine the meaning of the reply to link. The choice on allowing replies is up to the site owner. If they've state they don't want replies nested past a certain level, it would be completely irresponsible for us to make core 'override' that setting by still showing a reply link. People are smart enough to see that there is no reply link on one message but that there is one a level up, and just use that.

It might be worth pointing out that aside from the "reply" link, this is current behavior. I mean if you reply to a comment too deep and manually change the submitted parent comment ID, it does what mark-k describes.

comment:6 Denis-de-Bernardy4 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:7 in reply to: ↑ 4 joehoyle4 years ago

Replying to jane:

@mark-k: Yes, it can be a PITA, but it the blog owner's choice, not ours. We should not try to make core override the blog owner's choice. It's their site; WP is just the underlying platform.

Surely this is not overriding any functionality - overriding would be actually adding the extra depth. The Reply link becomes just a convenient way to add a reply to the parent comment. The blog owners are probably setting a max depth so they don't get really narrow comments, which doing the stated would not interfere with.

comment:8 hakre4 years ago

I've never heard that admins use the nesting-level setting to disable comments by setting it to zero.

comment:9 follow-up: dd323 years ago

  • Keywords dev-feedback added

Ok, Since denis re-opened this without a reason, are we sticking to the current behaviour?

The only way i can see this "working" would be for it to open the reply dialogue below the current comment level where the comment would then show up.. Which sounds like it'll be even stranger to me.

The initial release of threaded comments did not handle threading past the maximum very well, infact, it didn't handle it at all (comments would overflow to the end of the comment list all together) - for example when the threading depth was changed from 5 to 3, Adding comments deeper than the maximum to the maximum depth level is a relatively recent fix

comment:10 in reply to: ↑ 9 Denis-de-Bernardy3 years ago

Replying to dd32:

Ok, Since denis re-opened this without a reason (...)

Sorry. My battery was nearly dead the day I had done so and I forgot to get back onto it.

It seems to me that there is no reason for the reply link to not appear. For all I know, WP could even continue to track the nesting level for other themes that might support a higher one, as long as we're not actually displaying the excess nesting level.

As things stand it's confusing on WP devel, for instance, when the threading becomes a bit deep and you end up needing to scroll up in order to catch a reply link -- from a comment one that won't even be the correct one, at that.

comment:11 follow-up: dd323 years ago

  • Keywords dev-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

After talking it over, Closing as wontfix again.

It feels unnatural for the reply link on a comment to cause the comment reply to appear elsewhere. I believe users are smart enough to use the parents reply link.

comment:12 Denis-de-Bernardy3 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Sorry for re-opening, but... just take a look at this recent WP-devel thread, which is typical of what happens when there are multiple threads. While replying to:

http://wpdevel.wordpress.com/2011/01/14/clarification-in-licensing-language/#comment-15685

I end up with:

http://wpdevel.wordpress.com/2011/01/14/clarification-in-licensing-language/#comment-15699

Because I went for a Reply link -- one that should have been there in the first place -- in order to reply to Mark, I ended up clicking the wrong link.

Call me anal if you want, but this behavior is just wrong, wrong, wrong, and the reason you closed the ticket is just as wrong.

comment:13 follow-up: scribu3 years ago

I agree with Denis. Users are less confused by the lack of threading than by the lack of a reply link.

comment:14 scribu3 years ago

  • Milestone set to Future Release

comment:15 in reply to: ↑ 11 mark-k3 years ago

Replying to dd32:

After talking it over, Closing as wontfix again.

It feels unnatural for the reply link on a comment to cause the comment reply to appear elsewhere. I believe users are smart enough to use the parents reply link.

just 2 more cents:
This is not about being smart, but about not scrolling 3 pages up in order find the original comment, people who are not used to WP might not even notice/expect that there is a reply link in the original comment.

comment:16 follow-up: dd323 years ago

  • Keywords ux-feedback added

Whilst I talked it over with the lead devs and we agree'd that adding a reply link to a comment you cant reply to is crazy, I'm marking this as ux-feedback and leaving it at that.

The only alternative I could conceivably agree with would be having a reply link at the end of the maximum-nested level comments which added a reply at the same level.

comment:17 Denis-de-Bernardy3 years ago

There's something I really don't get in this... Aren't we managing the whole tree as if it had unlimited nesting level at all times, and formatting it using something like nesting_level = min(nesting_level, max_nesting_level)? If so, I fail to see how any reply link is not added; and if not, then, duh... why aren't we?

comment:18 in reply to: ↑ 16 ; follow-up: scribu3 years ago

Replying to dd32:

The only alternative I could conceivably agree with would be having a reply link at the end of the maximum-nested level comments which added a reply at the same level.

Yes, that's exactly what I was thinking of.

comment:19 in reply to: ↑ 18 markmcwilliams3 years ago

Replying to scribu:

Replying to dd32:

The only alternative I could conceivably agree with would be having a reply link at the end of the maximum-nested level comments which added a reply at the same level.

Yes, that's exactly what I was thinking of.

Me too when I commented all that time ago! :)

comment:20 scribu3 years ago

Related: #16430

comment:21 TheGremlyn3 years ago

If you're concerned about traceability of replies to original comments, why not add a link somewhere in the reply's box to link back to the originating comment. As an example, look at how Trac implements it's replies. The username of the person being replied to is a link back to their comment. I feel that as a user, I would be confused with a bunch of non-nested comments that are unclearly replying to something above it and as an admin I feel that allowing replies to comments at the max depth level completely negates to purpose of me setting the max depth in the first place.

Last edited 3 years ago by TheGremlyn (previous) (diff)

comment:22 in reply to: ↑ 13 chexee3 years ago

Replying to scribu:

I agree with Denis. Users are less confused by the lack of threading than by the lack of a reply link.

If the blog owner doesn't want another nested level, there shouldn't be another level of replies and if there is a reply link that doesn't actually reply to the comment its on. The inconsistent behavior could lead to more misunderstanding. The reply functionality should behave consistently so users aren't mislead or confused by the same link/function doing something different.

In short, I agree with TheGremlyn.

comment:23 travelvice3 years ago

I'd just like to throw my 2¢ into the hat on this, as I also find it a very confusing user interface experience to have to hunt down a parent comment to reply to one of its children.

I'd really love to add a 'reply to this thread' link to the last child of a thread. The other children above it need not have anything, but there really should be a simpler/clearer way to continue the thread at its current level.

Suggestions on how to craft a php workaround?

A custom function that's called for each comment:
"Am I a parent or child comment?"
 If parent: Display 'reply'
 If child: "Am I at max depth?"
  If at max depth: "Am I the last comment from this parent?"
   If last comment: Display link 'continue this thread'
   If not last comment: Display nothing
  If not at max depth: "Am I the last comment from this parent?"
   If last comment: Display two links - 'reply' and 'continue this thread'
   If not last comment: Display 'reply'
Last edited 3 years ago by travelvice (previous) (diff)

comment:24 Otto423 years ago

Just thinking aloud here, but why not allow replies to all levels, and make the threaded depth selection control display only?

I mean, there's no reason to think that you can't reply to a comment at level X just because X+1 is greater than the max-depth setting. People are changing the depth not to disallow comments, but to control their width/display in the theme. I'd be perfectly happy allowing infinite depth as long as it didn't make my comments too narrow on the page.

So my vote = always show the reply link, then use that max-depth to control how deep the display goes. For comments below that depth, show them on the same level as their parent, in the most natural display mechanism. This avoids the need to reply to the parent, ever, and it displays the comments in the most natural way. Also, if the user changes the max-depth, then the threading is maintained properly even at the new depth.

comment:25 scribu3 years ago

+1 for what Otto said.

comment:26 travelvice3 years ago

Agreed, although I wonder if there would be conversation readability issues if someone was able to insert their remarks (at a "max depth" level) when it couldn't be displayed as nested.

John
Sally
John
Sally
John

Then along comes Steve and interrupts the (flattened) flow:

John
Sally
John
Steve
Sally
John

Version 0, edited 3 years ago by travelvice (next)

comment:27 travelvice3 years ago

One last thought on Otto's:

For what it's worth, I gave a little test to a default install just to verify that type of functionality is already more or less active in there.
Comments that are nested several levels deep contract back to a restricted flow when the admin reduces the value for the number of threaded levels.

From comment-template.php

1308 // If we're at the max depth, and the current element still has children, loop over those and display them at this level
1309 // This is to prevent them being orphaned to the end of the list.

Perhaps the only solution for v2.7-present would be to set the depth at maximum (currently 10 levels) and use CSS to wrangle the comments into a single threaded view (for the preferred max depth). I believe this would allow for part Otto's suggested functionality to be used today -- although crippled when back & forth conversation reaches just a few replies.

Edit: Here's an interesting take on a workaround using jQuery

Last edited 3 years ago by travelvice (previous) (diff)

comment:28 jane3 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

The basic fact remains that "reply" has semantic meaning, and if it means one thing above level x and something different below level x, it's not consistent. If the issue is not wanting to scroll up a level to get a reply link, that's a theme display issue. The theme could just as easily add a link to comment on the thread in lieu of Reply. I'm voting wontfix -- again -- and would suggest someone do a plugin for this to prove that it's really necessary behavior in core before re-opening this ticket.

comment:29 SergeyBiryukov3 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.