WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#14552 closed defect (bug) (duplicate)

Eternal upgrade nag message with network and localized blogs

Reported by: nkuttler Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Multisite Keywords: has-patch dev-feedback
Focuses: Cc:

Description

I always get the "WordPress 3.0.1 is available! Please update now." nag message, when I dismiss it it comes back after some time.

To quote nacin from IRC:

In wp_version_check() we're asking for the locale via get_locale(), which in turn on some of your blogs is de_DE. So if that blog gets wp_version_check() triggered, then your transient will be showing the de_DE 3.0.1, which you're not running. If is_multisite() we should rely on get_site_option('WP_LANG') and WP_LANG, and we should ignore the individual blog settings. I'm actually not sure the best way to patch it.

I have attached a minimal patch but don't understand in full detail what's going on. The problem might be in the filter or somewhere else. The patch fixes the recurring nag messages.

Attachments (1)

eternal_nag_fix.diff (471 bytes) - added by nkuttler 11 years ago.

Download all attachments as: .zip

Change History (2)

#1 @nacin
11 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

You beat me by a few minutes. I'll mark as a duplicate of #14553 though and I'll be attaching a patch there soon.

Note: See TracTickets for help on using tickets.