WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#14563 closed defect (bug) (invalid)

Fail to apply changes to widgets and menu. Fail to apply changes with quick edit on posts, pages, categories.

Reported by: LordGordon Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Administration Keywords: reporter-feedback
Focuses: Cc:

Description

I installed a NEW WordPress 3.0.1 (no upgrade) on my hosted domain. I have some problems with menu, widget and quick edit post\page\category\link.

Every time I try to modify widgets (or add things on menu) nothing is saved: I click to save and the waiting icon appears, but never disappear (still remain up). Of course, nothing change on the website.
Same failure when I try to use quick edit on posts (also with quick edit for pages, categoires, links): changes are done only if I open the post editing page, but never change with quick edit.

On the same server I ran wordpress 2.9.1 with no errors.

Freqency: always

Steps to reproduce:

  1. log in admin panel
  2. go to appearance->widgets
  3. try to add, modify or remove widgets
  4. click to save

OR

  1. log in admin panel
  2. go to posts
  3. select quick edit
  4. change the title, or whatever else
  5. click to update

PHP: 5.2.14
MySQL: 5.1.48
hosted on Hostgator.com (shared hosting plan)

Theme: Twenty Teen
(same problem with others themes such as atahualpa, minicard)

Plugins: none (fresh new install)
(same with actived plugins such as: DBmanager, Login LockDown, Cron-GUI, ...)

Same problem with a newtork install (subdomain based)

Same problem both in 3.0 and 3.0.1 (currently running) with english or italian language installed.

Now I'm running the 3.0.1 network subdomain based with italian language enabled.

Change History (7)

comment:1 LordGordon4 years ago

  • Cc LordGordon added

comment:2 scribu4 years ago

  • Keywords reporter-feedback added; admin edit widget menu removed

It looks like there's something wrong with ajax requests.

What does Firebug say?

comment:3 LordGordon4 years ago

Thanks for your suggestion. I tried with Opera 10.11 and all is working as expected. The bug seems related to Firefox 3.6.1. Both running on Linux (Gentoo). I don't have other browser (and OSs) to test.

I tried to add the "search widget" with firebug enabled. Here the error:
POST http://nicholas.lordgordon.com/wp-admin/admin-ajax.php 404 Not Found 1.67s
http://nicholas.lordgordon.com/wp-admin/load-scripts.php?c=1&load=jquery,utils,swfobject&ver=cad485fb9c0b00570022e99105c16c6e

No other errors on console log.

comment:4 scribu4 years ago

Very strange. Maybe you have some Firefox plugin which is interfering.

comment:5 LordGordon4 years ago

The correct version is
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1) Gecko/20090621 Firefox/3.5
(and not 3.6.1 as stated before).

I solved using Opera.

Firefox Plugins:
NoScript*
Datafox
Delicious Bookmarks
DOM Inspector
Firebug
Download helper
External IP
Fast Dial
FlagFox
Greasemonkey
Novell MOonlight
Tab Preview
Tab Saver
Update notifier

*: All script enabled for my site (of course).

I'm going to check if some plugin is interfering.

comment:6 LordGordon4 years ago

Tested with:

firefox --safe-mode

(all themes, options, plugins disabled)
The error still occur!

By the way, my firefox is not updated to the newest version: this is not a "real bug". But I think this discussion could be useful for future reference.

If this bug is not reproducible on the newest firefox versions, I think should be closed.

comment:7 scribu4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Well, I'm using Firefox 3.6.8 and can't reproduce. Closing for now, until someone else can confirm the bug.

Note: See TracTickets for help on using tickets.