WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#14592 closed defect (bug) (worksforme)

Shortcode remains unrendered when wpautop removed

Reported by: davinic Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Shortcodes Keywords:
Focuses: Cc:

Description

My functions.php is removing the 'wpautop' filter from 'the_content'. When a page has a shortcode as the only content, the shortcode itself shows on the site. If I insert something before the shortcode, even a <br/>, the problem is resolved and the shortcode is rendered appropriately.

Windows Server 2003
IIS6

Change History (3)

comment:2 @Denis-de-Bernardy5 years ago

Meaning, sorry. :P

comment:3 @dd324 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I'm unable to reproduce on trunk.

remove_filter('the_content', 'wpautop'); in twentyten_setup() removed wpautop with ease, a single [gallery] as the only post content works for me.

I think there was a change in 3.1's regular expressions from memory, this may account for it.

Note: See TracTickets for help on using tickets.