WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#14603 closed defect (bug) (duplicate)

XMLRPC via WLW post revisions buggy and out of order

Reported by: archon810 Owned by:
Milestone: Priority: normal
Severity: major Version: 3.0.1
Component: XML-RPC Keywords: windows live writer, wlw, xml-rpc, xmlrpc, revisions
Focuses: Cc:

Description

When posting via Windows Live Writer to my 3.0.1 blog, I see a pretty big bug with revisions, compared to when posting via WP's interface.

Here's the problem: after updating a post with a few drafts between multiple authors, the draft history/compare page has all the names shifted in a really weird way. The first revision never gets into the list, the 2nd revision gets added as a 1st revision (the author of the 1st revision is shown as the author of the 2nd revision at this point), etc. It's an off-by-one problem.

I think it's easiest to understand the problem by looking at these 2 screenshots:

Test using WLW (Wave beta 4 but I don't think it matters) to post:
http://imgur.com/DKH9k.png

Test using WP's online interface to post:
http://imgur.com/7lNBG.png

In both cases, I have tested in the following manner:

  1. Create the first draft using user Artem
  2. Edit the draft using user test
  3. Look at the post again using user Artem in WP - what you will see is pictured above.

Looking at the database entries, the 2 methods seem to follow an entirely different flow, with 3 rows for WP's method and 2 rows for WLW.

Such wrong revision presentation actually confused me quite a bit when trying to compare revisions to figure out which author made a certain change. I blamed the wrong one :-]

I hope I've explained this clearly.

Thank you.

Change History (5)

comment:1 archon8104 years ago

  • Cc admin@… added

comment:2 redsweater4 years ago

  • Cc jalkut@… added

comment:3 mdawaffe3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Confirmed that the number of revisions differs. That's because the web updates an auto-draft, but the XML-RPC does not. I don't think that's an issue.

The wrong author thing is a duplicate of #16215.

comment:4 mdawaffe3 years ago

  • Milestone Awaiting Review deleted

comment:5 archon8103 years ago

Thanks for taking over, mdawaffe. Can we hope for a fix in 3.1?

Note: See TracTickets for help on using tickets.