Make WordPress Core

Opened 14 years ago

Closed 11 years ago

Last modified 5 years ago

#14634 closed enhancement (duplicate)

Add $args to get_the_terms()

Reported by: joehoyle's profile joehoyle Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Template Keywords:
Focuses: Cc:

Description

Currently, get_the_terms() only has two params: $id and $taxonomy. It would be good to have a third argument $args which could be passed to wp_get_object_terms()

Also, adding this to get_the_term_list() (which is when I found this problem) to pass to
get_the_terms()

Sorry if this has been brought up before, adding this would allow me to exclude the current term on my taxonomy list pages when I am using get_the_term_list() to show a list's terms.

Change History (8)

#1 @joehoyle
14 years ago

Also, I wil happily write the patch for this, should that route be chosen.

#2 @nacin
14 years ago

  • Milestone changed from Awaiting Review to Future Release

#3 @joehoyle
12 years ago

  • Keywords changed from get_the_terms, get_the_tmers_list to get_the_terms get_the_tmers_list
  • Version changed from 3.0.1 to 3.4.1

Almost a year with no activity, is it safe to assume there is no interest in this, and close. Or is it generally preferred to leave stuff in Future Release as one day it might get picked up?

As I said (2 years ago!) I will write the patch if it's likely to get accepted.

#4 @SergeyBiryukov
12 years ago

  • Keywords get_the_terms get_the_tmers_list removed
  • Version changed from 3.4.1 to 3.0.1

Related: ticket:9547:10

Version field indicates when the enhancement was initially suggested.

#5 @joehoyle
11 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Seems this will be fixed by #9547 when/if that path is committed

#6 @SergeyBiryukov
11 years ago

  • Resolution changed from invalid to duplicate

Duplicate of #9547.

#7 @SergeyBiryukov
11 years ago

  • Milestone Future Release deleted

This ticket was mentioned in Slack in #core-editor by nerrad. View the logs.


5 years ago

Note: See TracTickets for help on using tickets.