WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#14655 closed defect (bug) (fixed)

Malformed dashboard URL can cause infinite ajax recursion

Reported by: mdawaffe Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.0.1
Component: JavaScript Keywords: has-patch
Focuses: Cc:

Description

Kristian Erik Hermansen of Media Temple points out that visiting certain malformed dashboard URLs will cause an infinite loop of AJAX loads since we populate the index-extra.php loaded stuff via a relative URL instead of an absolute one.

Attached switches to an absolute URL.

Attachments (1)

14655.diff (1.3 KB) - added by mdawaffe 4 years ago.

Download all attachments as: .zip

Change History (5)

mdawaffe4 years ago

comment:1 ryan4 years ago

  • Milestone changed from Awaiting Review to 3.0.2

comment:2 ryan3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [15971]) Cause infinite recursion caused by malformed URLs. Props mdawaffe. fixes #14655

comment:3 ryan3 years ago

(In [15972]) Fix infinite recursion caused by malformed URLs. Props mdawaffe. fixes #14655

comment:4 ryan3 years ago

  • Milestone changed from 3.0.2 to 3.1
Note: See TracTickets for help on using tickets.