Make WordPress Core

Opened 5 years ago

Closed 12 months ago

Last modified 12 months ago

#14657 closed enhancement (duplicate)

Resync Boolean Type Case

Reported by: jacobsantos Owned by:
Milestone: Priority: normal
Severity: trivial Version:
Component: General Keywords: has-patch needs-refresh
Focuses: Cc:


TRUE to true and FALSE to false.

It seems patches weren't inline with the lowercase usage of the boolean type. Depends on programmer preference.

Attachments (1)

booleans_are_types.patch (42.2 KB) - added by jacobsantos 5 years ago.
Change case of booleans in files.

Download all attachments as: .zip

Change History (7)

@jacobsantos5 years ago

Change case of booleans in files.

comment:1 @hakre5 years ago

From what I remember, the use of the constants true and false should be lowercase. Patch looks good in that sense to me.

comment:2 @jacobsantos5 years ago

Well, to me they should be lowercase because of having to type them out a lot. The other reason is that language reserve words or keywords should always be lowercase to differentiate from other user defined terms.

The argument is whether or not the language type lowercase usage should be used verses the language implementation of them actually being constants, albeit case-insensitive constants.

The problem also is that if we switch over to using what is defined as constants, we'll have to use NULL instead of null as well.

comment:3 @nacin5 years ago

  • Keywords needs-refresh added; tested removed
  • Milestone changed from Awaiting Review to Future Release

No way this patch still applies.

This patches a few external libraries. We shouldn't patch those, it becomes more difficult to merge in changes from upstream later on.

comment:4 @jacobsantos3 years ago

  • Status changed from new to assigned

comment:5 @wonderboymusic12 months ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from assigned to closed

FALSE is in _http_build_query() once, but that's it. The rest are in external libraries.

comment:7 @SergeyBiryukov12 months ago

  • Resolution changed from wontfix to duplicate

Duplicate of #16302.

Note: See TracTickets for help on using tickets.