WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 8 years ago

#14660 closed enhancement (duplicate)

Hierarchical Page List in wp-admin/nav-menus.php

Reported by: ijaas Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Menus Keywords: needs-patch
Focuses: Cc:

Description

Shouldn't this list be hierarchical, i mean its kinda wack that it already isnt.
http://j.imagehost.org/0933/wp_menu_page.png

Attachments (4)

jq_menu_fix.js (923 bytes) - added by ijaas 9 years ago.
Javascript for fix for menus.
jq_menu_fix.php (1.2 KB) - added by ijaas 9 years ago.
PHP for fix for menus.
jq_menu_fix.png (136.3 KB) - added by ijaas 9 years ago.
End Result Sample
nav-menu.php (46.1 KB) - added by ijaas 9 years ago.
Modified wp-admin/includes/nav-menu.php

Download all attachments as: .zip

Change History (13)

#1 @mrmist
9 years ago

  • Component changed from General to Menus
  • Keywords needs-patch added; menu page list removed
  • Type changed from feature request to enhancement

Related #14325 #14332 #14538 one of which may be a duplicate even.

#2 @scribu
9 years ago

  • Severity changed from trivial to normal

#3 @radial
9 years ago

It would be extremely useful if this list was at least ordered alphabetically

@ijaas
9 years ago

Javascript for fix for menus.

@ijaas
9 years ago

PHP for fix for menus.

@ijaas
9 years ago

End Result Sample

@ijaas
9 years ago

Modified wp-admin/includes/nav-menu.php

#4 @ijaas
9 years ago

  • Cc ijaas added

quick jquery fix attached, along with modified wp-admin/includes/nav-menu.php

added to line 244 of wp-admin/includes/nav-menu.php:
$output .= '<input type="hidden" class="menu-item-the-id" name="menu-item. $possible_object_id .?[menu-item-the-id]" value="' . $item->ID . '" />';

probably not the best way to do this but it works for the time been.

#5 @nacin
9 years ago

  • Milestone changed from Awaiting Review to Future Release

For categories: #14180

#6 @keatch
9 years ago

  • Cc keatch@… added

#7 @hakre
9 years ago

Marked as duplicate: #15711

#8 @nacin
8 years ago

Closing this as a duplicate of #17029 since that ticket more clearly indicates the desired outcome, and we're still looking for a patch.

#9 @nacin
8 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.