WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#14695 closed enhancement (worksforme)

Banned Email Domain wildcards no longer work

Reported by: scytle Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Administration Keywords: email banned domain wildcards
Focuses: Cc:

Description (last modified by nacin)

In wpmu you used to be able to use wildcards to ban all of one type of domain for instance /.*\.info/ to ban all .info domains.

In wordpress 3.0 this seems to no longer work, in fact all my previous wild card entries seem to have been filtered out, and if I try to add them again some kind of filter removes them.

Anyone know how this might be resolved?

Thanks in advance.

Change History (7)

comment:1 follow-up: t31os_4 years ago

I can't replicate this problem, i'm able to save items into the blacklist option using either of the following (nothing gets removed on save).

/.*\.info/
*.info
*\.info

Tried to vary it a bit, because i wasn't sure exactly what you meant (i assume the second).

Tested under 3.0.1 and 3.1 (current trunk).

Works for me..

comment:2 in reply to: ↑ 1 scytle4 years ago

I was running wpmu 2.92 and upgraded using the button to wp 3.01...I meant the first one, but I tried all the ones you mentioned and they all get filtered out...

Replying to t31os_:

I can't replicate this problem, i'm able to save items into the blacklist option using either of the following (nothing gets removed on save).

/.*\.info/
*.info
*\.info

Tried to vary it a bit, because i wasn't sure exactly what you meant (i assume the second).

Tested under 3.0.1 and 3.1 (current trunk).

Works for me..

comment:3 follow-ups: wpmuguru4 years ago

  • Type changed from defect (bug) to enhancement

You could not use wildcard bans in MU 2.9.X (or anything past 2.7 IIRC). Setting this to an enhancement.

comment:4 in reply to: ↑ 3 ; follow-up: scytle4 years ago

Mine continued to work up until wp 3.0...odd.

Replying to wpmuguru:

You could not use wildcard bans in MU 2.9.X (or anything past 2.7 IIRC). Setting this to an enhancement.

comment:5 in reply to: ↑ 4 scytle4 years ago

Replying to scytle:

Mine continued to work up until wp 3.0...odd.

>
> Replying to wpmuguru:
> > You could not use wildcard bans in MU 2.9.X (or anything past 2.7 IIRC). Setting this to an enhancement.
I was told that you don't have to use wild cards anymore, that you can just put .info or .ru, I am testing it currently but it seems to work...

comment:6 in reply to: ↑ 3 scytle4 years ago

I don't know what I did up there but I am trying again.

I was told that you no longer have to use wild cards, that you can now use simply .ru or .info etc. I am testing it currently, but it seems to work...

Replying to wpmuguru:

You could not use wildcard bans in MU 2.9.X (or anything past 2.7 IIRC). Setting this to an enhancement.

comment:7 nacin3 years ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

"it seems to work..."

Note: See TracTickets for help on using tickets.