WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 14 months ago

#14697 closed enhancement (duplicate)

wp_list_comments not fully HTML5-friendly

Reported by: adamrice Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.0.1
Component: Comments Keywords: has-patch
Focuses: Cc:

Description

Currently, wp_list_comments supports ol, ul, and div as "styles" of nesting for threaded comments. While HTML5 is new enough that good markup practices are not entirely settled, the closest thing I've seen to a consensus is nested article elements.

This is currently not possible (except perhaps through a callback). Making it work right would also require inserting the comment classes as part of wp_list_comments' operation, which might require another parameter to turn it on.

I'm sure there are other WP functions that could use expanding to accommodate good HTML5 markup, but this is what jumped out at me.

Attachments (1)

14697.patch (1.2 KB) - added by jakub.tyrcha 4 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 @nacin4 years ago

  • Milestone changed from Awaiting Review to Future Release

@jakub.tyrcha4 years ago

comment:2 @jakub.tyrcha4 years ago

I'm wondering, maybe we should use pubdate and other html5 markup as well when the "article" styling is chosen

comment:3 @dd324 years ago

  • Keywords has-patch added; comment html5 removed

comment:4 @Umbercode3 years ago

I commented on the wrong thread, sorry.

Last edited 3 years ago by Umbercode (previous) (diff)

comment:5 @Zeokat14 months ago

What about this feature, we can´t use <article> HTML5 markup in wp_list_comments and after some years this feature should be definetly added.

comment:6 @SergeyBiryukov14 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

HTML5 support for wp_list_comments() was added in [23694]. Closing as a duplicate of #20088.

Note: See TracTickets for help on using tickets.