WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#14723 closed defect (bug) (duplicate)

Category hierarchy is not respected in admin section

Reported by: dans7919 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Administration Keywords:
Focuses: Cc:

Description

This bug has been around for several versions now, and it needs to be fixed. It's been reported several times, and always closed or rejected, with the comment that it's as designed. For example this bug report. http://core.trac.wordpress.org/ticket/10982

If it's as intended, then the individual who wrote this section of code isn't a very good developer. This section of code has severe usability issues when a blog has any amount of nested categorization.

The fact that a plug-in exists to address this issue, should be proof enough that this is a real bug/usability issue.
http://wordpress.org/extend/plugins/category-checklist-tree/

This could easily be fixed by adding an option to respect the hierarchy. Thus it could continue to work "as designed", as well as fix the issue with hierarchies.

Change History (1)

comment:1 scribu4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.