WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 5 years ago

#14745 closed defect (bug) (worksforme)

Renaming a Link-Category Resets Link Widget Options of that Category

Reported by: hakre Owned by:
Milestone: Priority: low
Severity: normal Version:
Component: Taxonomy Keywords: needs-patch
Focuses: Cc:

Description

When renaming the name of a Link Category that is used as well in a Link Widget, the Link Widget stops working.

Step to Reproduce:

  1. Create a Link Category "Test Start".
  2. Add 10 Links into the Category "Test Start".
  3. Go to the Widgets Screen and add a new Link Widget to a sidebar.
  4. Select that Link-Widget and set it from "All-Links" to the Category "Test Start".
  5. Visit your Frontpage so proof that the Widget displays.
  6. Go to the Link Cagegory Editor and quick-edit the "Test Start" Category.
  7. Rename it to "Test End".
  8. Save Changes.
  9. Visit your Frontpage.

=>> The Widget has disappeared.

Expected behavior: Widget displaying with the (renamed) link category.

Change History (4)

#1 @nacin
9 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release
  • Priority changed from normal to low

#2 @SergeyBiryukov
9 years ago

Can't reproduce on 3.1-RC1-17157. The widget stores only the category ID and uses wp_list_bookmarks() for display. Changing category name or slug doesn't seem to have any effect.

#3 @nacin
6 years ago

  • Component changed from General to Taxonomy

#4 @wonderboymusic
5 years ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

We haven't fidgeted with Links since 3.5. This works for me now.

Note: See TracTickets for help on using tickets.