WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 4 years ago

#14749 closed defect (bug) (wontfix)

Scrollbar position jumping in the Appearance->Editor newcontent textarea

Reported by: Giant Slayer Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Themes Keywords:
Focuses: administration Cc:

Description

As I am editing code in the Appearance Editor main textarea called newcontent, the scrollbar slider will jump upward to a new position moving the current line being edited down.

On a vista machine using ie8 with wp3.0.1 and the 2010 theme, a single character stroke will move the scrollbar up 3 lines.

On an xp machine using ie8 with wp3.0.1 and a custom theme, a single character stroke will move the scrollbar up 8 lines. Ocasionally the scrollbar will only move 1 line and every keystroke will bring the down. Pasting text can and often does bring the line being edited below the visible area of the textarea.

It is very frustrating when it jumps around like this.

Change History (5)

#1 @mrmist
9 years ago

i can confirm this. It's fairly annoying. Workaround is to use ie compatibility view though so have resisted raising.

#2 @solarissmoke
8 years ago

  • Keywords reporter-feedback added

Does this still happen in 3.1? I can't reproduce it.

#3 @helenyhou
7 years ago

  • Component changed from UI to Editor
  • Keywords reporter-feedback removed

It does still happen even now (3.4.2), seems to be caused by a weird IE8 conflict between the textarea's cols attribute and a CSS width: http://stackoverflow.com/questions/2933320/textareas-scroll-by-themselves-on-ie8-every-time-you-type-one-character. Not sure what we should do about it, though.

#4 @iseulde
5 years ago

  • Component changed from Editor to Themes
  • Focuses administration added
  • Keywords close added

Is this still a problem in WordPress 4.0? IE8 didn't change, so I assume so. Anything we can do about this? I'm tempted to close this.

Not sure where to put this, but this is not an editor issue (post.php).

#5 @chriscct7
4 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

No additional reports or requests in 3 years. IE8 support is deprecated since WordPress 3.3, and this is less of a bug and more of a nice to have thing. Closing as wontfix

Note: See TracTickets for help on using tickets.