WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#14775 closed defect (bug) (duplicate)

Image Widths set to Auto in style.css of Twenty Ten theme

Reported by: rfair404 Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Themes Keywords: Twenty Ten
Focuses: Cc:

Description

Twenty Ten sets image width and height in style.css line 762.

#content img {
	margin: 0;
	height: auto;
	max-width: 640px;
	width: auto;
}

When I use Twenty Ten as a parent theme, this attribute causes my child theme not to pass Theme Unit Testing - Images Alignment Test. Specifically the Centered Image with Caption and Wide Image, Resized In Editor sections.

Suggest removing line 764 and 766 of style.css

Attachments (1)

style.diff (393 bytes) - added by rfair404 4 years ago.
Possible Patch

Download all attachments as: .zip

Change History (2)

rfair4044 years ago

Possible Patch

comment:1 nacin4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of #14303.

Fyi, the stuff at the end has to do with line endings and whether there is a line break at the end of the file. Since I saw you asking in IRC. Gets cleaned up on commit usually, though it's nice to try to get it out of the patch file too.

Note: See TracTickets for help on using tickets.