WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#14784 closed defect (bug) (worksforme)

unable to change Link Category

Reported by: kelle Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

When attempting to change the category of a link (e.g., to remove it from my blogroll), upon clicking "update", the following message occurs:

Are you sure you want to do this?
Please try again.

The same error occurs in both FF and Safari.

Change History (2)

#1 @nacin
10 years ago

  • Keywords reporter-feedback added; links categories removed

This message is the result of a bad nonce.

However, I just tested the form and I was unable to reproduce. Additionally, the code appears to be generating and confirming the same nonces.

The main thing that causes this is a form that was opened to too long, beyond the 12/24 hour window. Or I suppose a conflicting plugin, or a form submission that isn't properly sending a referer.

#2 @dd32
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing as worksforme for now

Feel free to re-open if you can duplicate the issue on a new WordPress installation and can provide steps to reproduce it.

Note: See TracTickets for help on using tickets.