WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#14845 closed defect (bug) (worksforme)

Featured Image Bug - Featured image stays until pyshically deleted

Reported by: gutterboy333 Owned by:
Milestone: Priority: normal
Severity: major Version: 3.0.1
Component: Media Keywords:
Focuses: Cc:

Description

Ok.... first off I want to say I posted about this on the support forum & bumped it several times but no-one seemed to know anything, so I am posting it here.

Problem is when I upload an image after clicking the “Set featured Image” link, it will insert it as a header image whether I click the link to set it as a featured image or not... it just has to exist in the gallery. This means that even if I remove it as a featured image it will still show unless I actually delete the file altogether... obviously this is a HUGE problem if you have more than 1 image in your gallery.. as it will show any image it can find in there unless nothing exists.

Here is a screencast I took to show the problem in detail: http://www.screencast.com/t/MDFmYTg1OD

Each time I am going back to the page I am reloading it so you can see the outcome of the actions performed in admin.

Change History (1)

comment:1 @nacin5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce.

I can't find the code to your theme anywhere, but I imagine it always pulls an image in -- the post thumbnail if it exists, and the first gallery post if one isn't chosen.

Note: See TracTickets for help on using tickets.