Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#14894 closed defect (bug) (invalid)

Multisite bugs

Reported by: jfarthing84 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Multisite Keywords:
Focuses: Cc:


Maybe it's just me, but many of the cross-blog functions don't work as expected with multisite.

For instance, get_blog_permalink() returns a permalink formatted for the current blog (which doesn't even exist) rather than for the switched blog. This is reflected by not having the "subdirectory" of the switched blog.

Also, when using switch_to_blog() and then calling get_term_link(), the same results occur, as this is the same way that get_blog_permalink() works, except with get_permalink() instead of get_term_link() of course.

Am I misunderstanding something or is this a bug?

Change History (3)

#1 @jfarthing84
5 years ago

The same goes for get_blog_option(). It is returning options for the current blog when explicitly defining the blog id as the first parameter.

#2 @jfarthing84
5 years ago

  • Keywords dev-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

Ugh. So sorry guys. The issue was being caused by a plugin, namely W3 Total Cache. As soon as I disabled it, everything worked as expected.

#3 @nacin
5 years ago

  • Milestone Awaiting Review deleted

#12040, so not sure about everything. There's a plugin now for this, though.

Note: See TracTickets for help on using tickets.