WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#14925 closed defect (bug) (duplicate)

<span style="font-size: 13.3333px;">

Reported by: aercolino Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Editor Keywords:
Focuses: Cc:

Description

The real nasty things about this bug are:

  • It doesn’t show up in Firefox (the most common default browser among web developers)
  • It’s pretty common, but almost nobody noticed it
  • It shows up when doing/undoing a bullet list or a number list
  • The bug adds ghost spans, one per item, that you must remove manually
  • And manually means manually in HTML mode, because in Visual mode, the “Remove formatting” button usually removes too much formatting
  • The bug is so strong that if you remove the ghost spans and then undo a list, the same number of ghost spans are added back again
  • If you don’t remove the garbage as you go, it gets messier and messier, because the ghost spans start to appear also where never there has been a list
  • I wasn't able to find where the bug comes from: a search of all WordPress code returns nothing interesting

See: http://noteslog.com/post/wordpress-on-chrome-has-the-messiest-editing-bug/

See: http://www.google.es/search?ie=UTF-8&q='%3Cspan+style%3D%22font-size:+13.3333px;%22%3E'

See: http://wordpress.org/support/topic/bullet-points-change-font-and-layout-of-text

Change History (4)

comment:1 hakre4 years ago

Please provide a step by step guide how to reproduce here in this ticket. Thanks.

comment:2 hakre4 years ago

  • Keywords reporter-feedback added; Chrome bullet list span font-size 13.3333px removed

comment:3 nacin4 years ago

  • Keywords reporter-feedback removed

comment:4 nacin4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.