Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#14940 closed defect (bug) (wontfix)

After automatic upgrade, post-meta "enclosure" no longer being saved.

Reported by: jonathansampson Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Upgrade/Install Keywords: dev-feedback
Focuses: Cc:


After doing an automatic upgrade from 2.9.1 to 3.0.1, users will find that editing any published post will result in the loss of all custom field data for that particular post. Confirmed on Ubuntu and Windows. Problem persists in absence of all plugins.


  1. Download and install WordPress 2.9.1 with fresh db schema.
  2. Edit default post to add new custom field enclosure => somevalue.
  3. Update default post, and confirm continued existence of custom field.
  4. Perform automatic update to WordPress 3.0.1.
  5. Open default post for editing, make no changes, press "update."
  6. Navigate back to posts page, and re-open default post again - custom field has been deleted.

Change History (4)

#1 @ericmann
5 years ago

  • Cc eric@… added
  • Component changed from General to Upgrade/Install
  • Keywords dev-feedback added; custom values meta removed
  • Severity changed from major to normal

#2 @scribu
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

That's because 'enclosure' is a special custom field, manipulated by do_enclose(). You should never set it manually.

#3 @hakre
5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from After automatic upgrade, post-meta no longer being saved. to After automatic upgrade, post-meta "enclosure" no longer being saved.

Looks like this is an issue in migrating from 2.9 to 3.0.

This case should be handeled in the upgrade process if it never should been set manually because it was totally okay for 2.9 to use the field manually (or wasn't it?)

If it should never been set manually, it should been blocked in 3.x. I could add a custom post name "enclosure" in the 3.1-alpha post editor. Looks like the UI is not properly blocking it. It did not even do any warning it's just not displayed after being added.

#4 @hakre
5 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

But this will be never fixed I guessed.

Note: See TracTickets for help on using tickets.