WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14947 closed defect (bug) (invalid)

Cannot remove all taxonomy terms from a post

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.0.1
Component: Taxonomy Keywords:
Focuses: Cc:

Description

Forgive the quick report but I'm filing this before I have to run out the door.

Situation: Standard list of term checkboxes for a custom taxonomy on the post editing screen. Once you've checked some boxes and saved the post it's impossible to then remove all the terms by unchecking all the checkboxes and saving the post. The previous selection of terms remains when the post gets saved. Off the top of my head I should think that the taxonomy doesn't get updated if the tax_input array for that taxonomy is empty.

Change History (6)

comment:1 duck_4 years ago

Maybe I'm not doing something you are, but cannot reproduce on either trunk or 3.0.1

comment:2 follow-up: scribu4 years ago

  • Keywords reporter-feedback added

Are you using Quick Edit by any chance?

comment:3 in reply to: ↑ 2 nacin4 years ago

Replying to scribu:

Are you using Quick Edit by any chance?

My first thought. But we fixed that too: [14117]

comment:4 johnbillion4 years ago

This seems to be a local issue. I'll test and update accordingly.

comment:5 johnbillion4 years ago

  • Keywords reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

The site is using a custom meta box for the taxonomy and it turns out it didn't include the hidden tax_input[my_tax][] field. Adding the hidden field in fixes the problem.

comment:6 scribu4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.