WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14952 closed defect (bug) (fixed)

Nav menu screen options are broken

Reported by: nacin Owned by: scribu
Milestone: 3.1 Priority: high
Severity: major Version: 3.1
Component: General Keywords:
Focuses: Cc:

Description

Normally we're able to show/hide different fields. Right now all are shown and nothing shows up in screen options.

Change History (3)

comment:1 scribu4 years ago

  • Owner set to scribu
  • Status changed from new to accepted
  • Version set to 3.1

comment:2 scribu4 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [15653]) Column headers revamp:

  • undeprecate get_column_headers()
  • undeprecate get_hidden_columns()
  • in WP_List_Table, rename get_column_headers() to get_column_info()
  • remove $taxonomy argument from single_row()
  • merge manage_columns_prefs() into screen_meta()

Fixes #14952. Fixes #14776.

comment:3 nacin4 years ago

(In [15662]) Prevent the $title global from being stomped. Caused by merger of manage_columns_prefs() into screen_meta() in [15653]. see #14952, see #14776. The global is apparent cruft as the function doesn't use it.

Note: See TracTickets for help on using tickets.