WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#14957 closed defect (bug) (duplicate)

Wrong username shown as "currently editing this post"

Reported by: elyograg Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Editor Keywords: currently editing wrong username
Focuses: Cc:

Description

I have a number of authors on a blog that I am developing. When I am reviewing posts made by other users, it sometimes tells me that the post creator is editing the post.

This is not actually the case - it's me that is editing the post. To reproduce:

Edit a post created by another user.
Reload the page.
It will say "Warning: otherusername is currently editing this post"

It should report the correct username, but if the logged in person is the one who is editing it, then it shouldn't display it at all.

Change History (3)

comment:1 @scribu5 years ago

I'm pretty sure there was a similar bug opened a couple of versions back, but I can't seem to find it now.

comment:2 @dd325 years ago

Another ticket with ultimately, the same root cause i'd say (Given that its all based on Revisions and post locks) #11022 - There IS another ticket however which deals with this specific issue, i have a feeling it was one of the gsoc tickets mentioned that it'd be good for new contributors to test their teeth on..

comment:3 @dd324 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #15130 fixed in 3.1

Note: See TracTickets for help on using tickets.