WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#14962 closed defect (bug) (worksforme)

OperationalError: database is locked

Reported by: azizur Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

How to Reproduce

While doing a POST operation on /ticket/12702, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'cbc90d6a17e42677f6496c53',
 'action': u'leave',
 'cnum': u'16',
 'comment': u"New Patch ready for review.\r\n\r\nI assumed as part of the 3.1 release we'd have an upgrade script to move current stickies to new format (stickies grouped by post type).",
 'field_component': u'Post Types',
 'field_keywords': u'needs-patch',
 'field_severity': u'normal',
 'field_summary': u'Enable sticky post checkbox for custom post type Publish metabox',
 'field_type': u'feature request',
 'field_version': u'',
 'id': u'12702',
 'replyto': u'',
 'submit': u'Submit changes',
 'ts': u'2010-09-11 01:06:47+00:00'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

System Information

Trac 0.11.7
Python 2.4.4 (#1, Jan 24 2010, 11:47:59)
[GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)]
setuptools 0.6c9
SQLite 3.3.8
pysqlite 2.3.2
Genshi 0.5
Pygments 0.10
RPC 1.1.0-r7971
Subversion 1.4.2 (r22196)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/ticket/web_ui.py", line 182, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/ticket/web_ui.py", line 513, in _process_ticket_request
    self._do_save(req, ticket, action)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/ticket/web_ui.py", line 1034, in _do_save
    cnum=internal_cnum):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/ticket/model.py", line 287, in save_changes
    (self.id, when_ts, author, cnum, comment))
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/db/util.py", line 64, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/db/sqlite_backend.py", line 80, in execute
    result = PyFormatCursor.execute(self, *args)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/db/sqlite_backend.py", line 59, in execute
    args or [])
  File "/usr/lib/python2.4/site-packages/Trac-0.11.7-py2.4.egg/trac/db/sqlite_backend.py", line 51, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked


Change History (1)

comment:1 nacin4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

This will happen sometimes due to the server this runs on. You'll just have to re-submit the form (say yes to POSTDATA etc) and it should work after a try or two.

There will be some infrastructure changes in the future but it does not need to be high priority as everything normally works quite well.

Note: See TracTickets for help on using tickets.