Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#14970 closed defect (bug) (fixed)

3.1-alpha Network Options page results in 404 error on "Save Changes"

Reported by: moose123 Owned by: scribu
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: Multisite Keywords:
Focuses: Cc:



  • Running 3.1 alpha trunk version w/ Network enabled.
  • Server: RedHat Linux, Apache/2.2.3 (CentOS).


Logged in as Site Admin, on the Network Admin > Network Options page. When I save my changes, it redirects to a Page Not found page. So this page:


sends me to a 404 when I save changes with the error:

"The requested URL /wp-admin/settings.php was not found on this server."

This is confusing because the form action code looks correct:

<form method="post" action="edit.php?action=siteoptions">
<input type="hidden" id="_wpnonce" name="_wpnonce" value="a6d4643888" />
<input type="hidden" name="_wp_http_referer" value="/wp-admin/network/settings.php" />
  • Have reproduced it in Firefox, Safari and IE on Windows and FireFox on Linux.
  • All other admin functions working great.
  • I have disabled my two plugins and am running the default theme but still getting the 404 page when I save changes to network options.

Per the network config page, my wp-config.php and .htaccess code is set up as such:


define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', false );
$base = '/';
define( 'DOMAIN_CURRENT_SITE', 'wp.mysite.com' );
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );


RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

Please let me know if any more information is needed.

Thanks very much for any help.

Change History (3)

#1 @scribu
5 years ago

  • Milestone changed from Awaiting Review to 3.1
  • Owner set to scribu
  • Status changed from new to accepted

This was probably caused by the ajaxification. Working on a patch.

#2 follow-up: @scribu
5 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [15669]) Fix redirection when saving network settings. Fixes #14970

#3 in reply to: ↑ 2 @moose123
5 years ago

Replying to scribu:

(In [15669]) Fix redirection when saving network settings. Fixes #14970

Thank you! Works great now.

Note: See TracTickets for help on using tickets.