WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#14974 closed defect (bug) (duplicate)

3.1 alpha: "Fatal error: Cannot redeclare..." on plugin Network Activate

Reported by: moose123 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Administration Keywords: reporter-feedback
Focuses: Cc:

Description

Environment

  • Running 3.1 alpha trunk version w/ Network enabled.
  • Server: RedHat Linux, Apache/2.2.3 (CentOS).

Problem

When trying to Network Activate a plugin, I receive the following error. It happens for both of my plugins (the other one is Hello Dolly), but this particular one is from Akismet:

Plugin could not be activated because it triggered a fatal error.

Fatal error: Cannot redeclare akismet_init() (previously declared in /home/mysite/public_html/wordpress/wp-content/plugins/akismet/akismet.php:48)
in /home/mysite/public_html/wordpress/wp-content/plugins/akismet/akismet.php on line 59

I'm guessing I need to report this to the plugin author, but I thought I should post it here, as well.

Thanks very much for your help.

Change History (7)

comment:1 scribu4 years ago

Can't reproduce. Are you sure you don't have something in your mu-plugins that might be interfering?

comment:2 scribu4 years ago

  • Keywords reporter-feedback added

comment:3 scribu4 years ago

Ah... I see the error if the plugin is already (normally) activated on a single site. Is that the case for you too?

comment:4 moose1234 years ago

I just have my main site and one test network site. Neither plugin was enabled on the test site, but I was just able to activate both plugins successfully on the test site no problem.

But back in Site Admin > Plugins I still get the "Fatal error: Cannot redeclare..." error on Network Activate.

(FYI, this was a fresh install of Wordpress as opposed to an upgrade from an earlier Mu installation, if that helps any.)

Something else I just noticed is that when I click on the 'edit' link under each plugin, I get a page not found error. It seems to be looking for "wp-admin/network/plugin-editor.php."

http://wp.mysite.com/wp-admin/network/plugin-editor.php?file=akismet/akismet.php
http://wp.mysite.com/wp-admin/network/plugin-editor.php?file=hello.php

Thanks so much for your rapid responses.

comment:5 scribu4 years ago

My steps to reproduce:

  1. Go to the main site admin
  2. Activate Akismet
  3. Go to the network admin
  4. Activate Akismet

Result: Fatal error: Cannot redeclare akismet_init()...

Something else I just noticed is that when I click on the 'edit' link under each plugin, I get a page not found error. It seems to be looking for "wp-admin/network/plugin-editor.php."

Please report that and other similar issues here: #14435

comment:6 moose1234 years ago

Your steps to reproduce are the same for me.

I've reported the other issue at http://core.trac.wordpress.org/ticket/14435. Seems someone else reported the same issue some weeks ago.

Thanks.

comment:7 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Fixed in trunk.

Note: See TracTickets for help on using tickets.