WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#14984 closed enhancement (duplicate)

No backlink in comment error messages

Reported by: doktorbro Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Comments Keywords: UI
Focuses: Cc:

Description

If a commenter press "Post comment" but forget to leave name, email or comment, he gets a white screen with an error like: "Error: please type a comment."

The shocked user thinks: "What now? Am I stupid? Is this the White Window of Shame?"

The answer is always: "Go back and try it again." That's why we need to put that obvious hint: "Back" by default. It's so easy to be friendly :-)

Change History (7)

comment:1 doktorbro4 years ago

  • Cc bro@… added
  • Owner wp-comments-post.php deleted
  • Status changed from new to assigned

comment:2 follow-up: RAMIY4 years ago

  • Cc RAMIY added
  • Component changed from Warnings/Notices to Comments

I agree, we have to change the white screen. The "Back" link is a nice start but we need to allow users to change the error message the page design.

comment:3 in reply to: ↑ 2 doktorbro4 years ago

Replying to RAMIY:

I agree, we have to change the white screen. The "Back" link is a nice start but we need to allow users to change the error message the page design.

Yes, design is important. But the "Back" link only is a huge step. Start it, please. All you have to do, is change

wp_die( __('Error: please type a comment.') );

to something like

wp_die(  __('Error: please type a comment.') ,
__('Error: please type a comment.') . ' | ' . get_bloginfo ( 'name' ),
array( 'response' => 500, 'back_link' => true ) );

comment:4 nacin4 years ago

  • Milestone changed from Awaiting Review to Future Release

I think it would be better if we came up with a way to easily leverage comment_form() presence and return a friendly, theme-wrapped error message.

This is likely a duplicate of other tickets, in that case.

comment:6 johnbillion3 years ago

  • Resolution set to duplicate
  • Status changed from assigned to closed

comment:7 dd323 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.