WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15007 closed defect (bug) (fixed)

$wp_query->query_vars['cat'] not set properly

Reported by: ryan Owned by: scribu
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: Taxonomy Keywords:
Focuses: Cc:

Description (last modified by ryan)

I've noticed some themes are returning the same content for all categories when running current trunk (when visiting /category/foo|bar|baz). They have usage of $wp_query->query_vars['cat'] in common. Switching them to get_queried_object_id() fixes them, but we should preserve back compat.

Change History (5)

#1 @ryan
7 years ago

  • Description modified (diff)

#2 @scribu
7 years ago

  • Owner set to scribu
  • Status changed from new to accepted

Caused by #15007.

I'm on it.

#3 @scribu
7 years ago

#12891 I mean.

#4 @scribu
7 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [15685]) Set 'cat' query var for backwards compatibility. Fixes #15007

#5 @hakre
7 years ago

Related: #16465

Note: See TracTickets for help on using tickets.