WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 10 months ago

#15052 closed defect (bug) (duplicate)

The screen turns white once I add over 4000 pages.

Reported by: Lyncis Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Performance Keywords:
Focuses: Cc:

Description

Dear Sirs! While attempting to post over 4000 pages using wordpress, a part of admin interface dies instantly (I am talking about the part showing the list of website pages)and also the frontend goes dead. I suspect that the problems is caused by the "wp_list_pages" function, which in turn summons another function, which is "get_pages". In the line 3177 of the "get_pages" functions there is /wp-includes/post.php contains SQL call which draws all the date from the POSTS table:
$query = "SELECT * FROM $wpdb->posts $join WHERE ($where_post_type) $where ";
A part of it is in an unnecessary field, namely post_content – which I see as the cause of wordpress failure once great number of pages is added.

Change History (7)

comment:1 mikeschinkel4 years ago

  • Cc mikeschinkel@… added

comment:2 scribu4 years ago

Related: #14777

comment:4 hakre4 years ago

  • Keywords reporter-feedback added; wp_list_pages get_pages removed

Lyncis can you please enable error logging and WP_DEBUG? Some additional information shuld be kept in the PHP error log then. Please share.

comment:5 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

We're not ready to push this. You'll want to just bump your memory.

comment:7 SergeyBiryukov10 months ago

  • Keywords reporter-feedback removed
  • Resolution changed from maybelater to duplicate

Duplicate of #15459.

Note: See TracTickets for help on using tickets.