Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#15070 closed defect (bug) (duplicate)

WordPress cuts short links with "!"

Reported by: larysa Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Comments Keywords:
Focuses: Cc:


Short links that have an exclamation point in the URLs [ "!" ] posted in comments are "cut" by the WP.

For instance, WordPress cuts http://name.ly/!Bd$8N down to http://name.ly/

Facebook and Twitter, for instance, handle such links correctly.

As it is 100% legal URL syntax [ http://en.wikipedia.org/wiki/URL ] to have "!" in the URL, such cuts are annoying.

WP should not cut the URLs downto "!" character but parse it to the next space or new line character.

Change History (3)

comment:1 @coffee2code5 years ago

  • Keywords URL comments link removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14993.

comment:2 @scribu5 years ago

  • Milestone Awaiting Review deleted

comment:3 @mrmist5 years ago

  • Type changed from enhancement to defect (bug)
Note: See TracTickets for help on using tickets.