WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#15077 closed defect (bug) (duplicate)

is_active_sidebar() cannot accept a sidebar name as input

Reported by: dvmorris Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Widgets Keywords: sidebar
Focuses: Cc:

Description

If I send a sidebar name, such as "Right Sidebar", to is_active_sidebar($index), it does not properly translate the name into the sidebar id. The function is on line 971 of wp-includes/widgets.php, and the @param comment implies that it is able to accept sidebar names as input.

If you replace line 972 with the logic from dynamic_sidebar() on lines 842-854, it works properly. Perhaps these lines of code should be moved to a function so they do not need to be repeated twice to fix this issue.

Change History (3)

#1 @nacin
11 years ago

I know I asked for this ticket, but I forgot #11160, and I think this is a duplicate of that, yes?

#2 @dvmorris
11 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Yes, I believe that fix would take care of this issue. Duplicate of #11160.

#3 @nacin
11 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.