WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#15108 closed defect (bug) (fixed)

import of wxr duplicates non-defined categories

Reported by: steph Owned by:
Milestone: 3.1 Priority: normal
Severity: minor Version: 3.0
Component: Import Keywords: reporter-feedback
Focuses: Cc:

Description

While merging two blogs, I did the following: exported posts from blog B, deleted all taxonomy information from the beginning of the file (I only wanted certain posts and didn't want to duplicate the taxonomy in blog A) and imported into blog A.

All posts in the wxr file were in category C, which was recreated for each post in the list (I ended up with 25 categories called "mycategory", with slugs "mycategory-1", "mycategory-2", etc.

Tags were fine and as far as I can see the rest of the import worked normally.

Change History (3)

#1 @duck_
7 years ago

  • Keywords reporter-feedback added

I may not have followed your steps exactly as I don't think I understood them completely, but I couldn't reproduce what I think you're describing. A few more details to make the situation clearer would be useful (e.g. the actual category name or a sample WXR file if possible).

Probably related to #5447 and #5454

Aside: I'm working on some fixes to the WXR importer and exporter and should have something to show soon.

#2 @nacin
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [15961]) Importer and exporter overhaul, mega props duck.

Exporter overhaul:

  • Add author information to export
  • Greater usage of slug identifiers
  • Don't export auto-drafts, spam comments, or edit lock/last meta keys
  • Inline documentation improvements
  • Remove filtering for now (@todo)
  • Bump WXR version to 1.1, but remain back compat in the importer

Importer overhaul (http://plugins.trac.wordpress.org/changeset/304249):

  • Use an XML parser where available (SimpleXML, XML Parser)
  • Proper import support for navigation menus
  • Many bug fixes, specifically improvements to category and custom taxonomy handling
  • Better author/user mapping

Fixes #5447 #5460 #7400 #7973 #8471 #9237 #10319 #11118 #11144 #11354 #11574 #12685 #13364 #13394 #13453 #13454 #13627 #14306 #14442 #14524 #14750 #15055 #15091 #15108.

See #15197.

#3 @nacin
7 years ago

  • Milestone changed from Awaiting Review to 3.1
Note: See TracTickets for help on using tickets.