WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#15138 closed defect (bug) (fixed)

404 Errors When Downloading Plugins From Wordpress.org Repository

Reported by: chrisvrichardson Owned by: mdawaffe
Milestone: WordPress.org Priority: high
Severity: critical Version:
Component: WordPress.org site Keywords: 404
Focuses: Cc:

Description

My plugin is hosted in the repository at wordpress.org. The "download" button there is not working and returns 404 errors most (but not all) of the time. The broken link also causes errors in when updating the plugin from the wordpress administration screens: "Download failed. Not found"

I've been getting a lot of email from users who cannot download so the problem is unique to me.

When I've tried the download link it doesn't always fail: I get a 404 error about 75% of the time. The other 25% it downloads the current version's zip file correctly.

The plugin is here:
http://wordpress.org/extend/plugins/mappress-google-maps-for-wordpress

The link to the current zip is:
http://downloads.wordpress.org/plugin/mappress-google-maps-for-wordpress.2.18.zip

I hope this is the correct way to request assistance with this issue, and thanks for your help!

Change History (43)

#1 @scribu
7 years ago

  • Milestone changed from Awaiting Review to WordPress.org site

#2 @ramoonus
7 years ago

got the same problem

#3 @psykonevro
7 years ago

  • Cc psykonevro added
  • Keywords plugin download 404 added

I've exactly same issue with my plugin

IMDb link transformer

As said, I can't reproduce the problem with every download; sometimes a 404 occurs, sometimes not.

#4 @eskapism
7 years ago

Don't know if this helps, but this is the output from wget. First try = fail. Second try = works.


wget -S http://downloads.wordpress.org/plugin/cms-tree-page-view.0.7.8.zip
--2010-10-18 08:51:39-- http://downloads.wordpress.org/plugin/cms-tree-page-view.0.7.8.zip
Resolving downloads.wordpress.org... 72.233.56.138, 72.233.56.139
Connecting to downloads.wordpress.org|72.233.56.138|:80... connected.
HTTP request sent, awaiting response...

HTTP/1.0 404 Not Found
Content-Type: text/html; charset=UTF-8
Content-Length: 19
Date: Mon, 18 Oct 2010 06:51:40 GMT
Server: LiteSpeed
Connection: close

2010-10-18 08:51:40 ERROR 404: Not Found.


wget -S http://downloads.wordpress.org/plugin/cms-tree-page-view.0.7.8.zip
--2010-10-18 08:51:44-- http://downloads.wordpress.org/plugin/cms-tree-page-view.0.7.8.zip
Resolving downloads.wordpress.org... 72.233.56.138, 72.233.56.139
Connecting to downloads.wordpress.org|72.233.56.138|:80... connected.
HTTP request sent, awaiting response... [[A

HTTP/1.0 200 OK
Pragma: no-cache
Cache-control: private
Content-Description: File Transfer
Content-Type: application/octet-stream
Content-Disposition: attachment; filename=cms-tree-page-view.0.7.8.zip
Date: Mon, 18 Oct 2010 06:51:45 GMT
Server: LiteSpeed
Connection: close

Length: unspecified [application/octet-stream]
Saving to: `cms-tree-page-view.0.7.8.zip'

#5 @mrmist
7 years ago

  • Keywords plugin download 404 removed

This issue has also been reported separately on the forums a few times.

#6 @micropat
7 years ago

  • Summary changed from 404 Errors When Downloading My Plugin From Wordpress.org Repository to 404 Errors When Downloading Plugins From Wordpress.org Repository

Would just like to clarify that this is affecting a number of plugins, not just one.

I deployed a release of the AddToAny plugin yesterday and the current version is having sporadic download issues (sometimes works, sometimes a 404).

Older versions seem to be downloading just fine. (Correct me if I'm wrong.)

#7 follow-ups: @mdawaffe
7 years ago

  • Owner set to mdawaffe
  • Priority changed from normal to high
  • Severity changed from blocker to critical
  • Status changed from new to assigned
  • Version 3.0.1 deleted

The plugins directory got out of sync somehow. Some of the servers thought they had only synced up to svn rev 7k (HEAD is currently > 300k), so were stuck processing (really) old commits instead of new ones. I'm not sure what caused the bug, but I've added a sanity check to prevent something similar from happening in the future.

The servers are resyncing now, but it will probably be a bit more than a day before they get back up to speed completely.

We're looking at reworking how downloads are processed so that no syncing is required at all. That change isn't going to happen right away, though.

#8 @RavanH
7 years ago

Thanks man! I thought it might have something to do with the content of my readme or main plugin file tags... so I was slowly going crazy, changing all kinds of stuff in there ;)

Glad to hear it's being dealt with :)

#9 follow-up: @elfin
7 years ago

  • Cc elfin@… added

I actually reported this to plugins@… didn't anyone pick that up?

#10 follow-up: @ScribeSEO
7 years ago

Question, during the wait for the sync process to complete, would it be better to release an incremental tag release (ie 3.0.8.1) along with the trunk update OR to wait for the sync. We are experiencing this issue now and getting a lot of support requests. Not sure if we should wait and would appreciate some advice (incremental tag or wait).

#11 follow-up: @freediver
7 years ago

  • Cc freediver added

Adding to debug efforts

There seems to be a problem with repository manifesting with plugin SEO Friendly Images

http://wordpress.org/extend/plugins/seo-image/

WordPress page indicates version 2.6 is latest, which is what the plugin update also indicated, but both automatic update and the download link http://downloads.wordpress.org/plugin/seo-image.zip download version 2.4.4

Many users have complained they can not upload the plugin through automatic update. Version 2.6 can be downloaded normally through 'Other versions' link http://wordpress.org/extend/plugins/seo-image/download/

Just the main archive file seems to be broken.

#12 in reply to: ↑ 10 @mdawaffe
7 years ago

Replying to ScribeSEO:

Question, during the wait for the sync process to complete, would it be better to release an incremental tag release (ie 3.0.8.1) along with the trunk update OR to wait for the sync. We are experiencing this issue now and getting a lot of support requests. Not sure if we should wait and would appreciate some advice (incremental tag or wait).

Wait. The sync moves up revision by revision; new commits will be processed only after the old ones.

#13 in reply to: ↑ 11 @mdawaffe
7 years ago

Replying to freediver:

Many users have complained they can not upload the plugin through automatic update. Version 2.6 can be downloaded normally through 'Other versions' link http://wordpress.org/extend/plugins/seo-image/download/

The main download link is pulling from trunk (since you have Stable Tag: trunk in your readme.txt http://plugins.svn.wordpress.org/seo-image/trunk/readme.txt )

Some servers are completely up to date and always have been, while others are behind. So some people may be able to download things that others cannot. If you're having better luck with /tag/2.6 then /trunk, you can try switching your stable tag to 2.6. The DB is (and always was) in sync, so that change will get picked up quickly (it's the zip files that are not fully synced).

I'll try to speed up the sync process a bit.

#14 in reply to: ↑ 9 ; follow-up: @mdawaffe
7 years ago

Replying to elfin:

I actually reported this to plugins@… didn't anyone pick that up?

Yes - we responded to most of the emails. Looks like yours fell through the cracks, sorry ;(

#15 in reply to: ↑ 14 ; follow-up: @elfin
7 years ago

Replying to mdawaffe:

Yes - we responded to most of the emails. Looks like yours fell through the cracks, sorry ;(

Just glad it was received, as I've sent a few other things in recently as well.

Using trac to report site bugs is still slightly alien to me, I'll get there eventually.

#16 in reply to: ↑ 15 @mdawaffe
7 years ago

Replying to elfin:

Using trac to report site bugs is still slightly alien to me, I'll get there eventually.

Both help, so no need to change your behavior IMO. Thanks for the report!

#17 in reply to: ↑ 7 ; follow-up: @jeremyhixon
7 years ago

Replying to mdawaffe:

The plugins directory got out of sync somehow. Some of the servers thought they had only synced up to svn rev 7k (HEAD is currently > 300k), so were stuck processing (really) old commits instead of new ones. I'm not sure what caused the bug, but I've added a sanity check to prevent something similar from happening in the future.

I'm experiencing the same issue with my, recently submitted, plugin. Another user has started a thread with another issue when using the WordPress installer to add my plugin.

http://wordpress.org/support/topic/plugin-wp-admin-menu-cant-install-from-wordpress-installer?replies=2

Could this 404 error also be responsible for his fopen() errors?

#18 in reply to: ↑ 17 ; follow-up: @mdawaffe
7 years ago

Replying to jeremyhixon:

http://wordpress.org/support/topic/plugin-wp-admin-menu-cant-install-from-wordpress-installer?replies=2

Could this 404 error also be responsible for his fopen() errors?

Yes. I responded on that thread.

#19 in reply to: ↑ 18 @jeremyhixon
7 years ago

Replying to mdawaffe:

Yes. I responded on that thread.

Thank you for that

#20 in reply to: ↑ 7 @mdawaffe
7 years ago

Replying to mdawaffe:

The plugins directory got out of sync somehow. Some of the servers thought they had only synced up to svn rev 7k (HEAD is currently > 300k), so were stuck processing (really) old commits instead of new ones. I'm not sure what caused the bug, but I've added a sanity check to prevent something similar from happening in the future.

The servers are resyncing now, but it will probably be a bit more than a day before they get back up to speed completely.

Thanks to the inimitable Barry, the sync process is now complete much sooner than I expected.

Everything should be working correctly now. If you see any problems, please say so.

#21 follow-up: @arena
7 years ago

Hi !

don't know if it is the same issue.

when i try to download previous versions of my plugin, i get an empty folder !!

http://wordpress.org/extend/plugins/mailpress/download/

#22 follow-up: @bueltge
7 years ago

  • Cc frank@… added

I have also an problem only at one plugin from my plugins, maby is the same topic.
http://wordpress.org/extend/plugins/adminer/
please see this thread in the forum, is an better english as my:
http://wordpress.org/support/topic/plugin-adminer-upgrade-loop-with-101

#23 @ramoonus
7 years ago

  • Cc ramoonus@… added

#24 @ramoonus
7 years ago

  • Cc ramoonus@… removed

#25 in reply to: ↑ 21 ; follow-up: @barry
7 years ago

Replying to arena:

Hi !

don't know if it is the same issue.

when i try to download previous versions of my plugin, i get an empty folder !!

http://wordpress.org/extend/plugins/mailpress/download/

Maybe - which version(s) did you try downloading? I couldn't replicate it just now.

#26 in reply to: ↑ 22 @barry
7 years ago

Replying to bueltge:

I have also an problem only at one plugin from my plugins, maby is the same topic.
http://wordpress.org/extend/plugins/adminer/
please see this thread in the forum, is an better english as my:
http://wordpress.org/support/topic/plugin-adminer-upgrade-loop-with-101

Hi - it looks like you got this fixed?

#27 @AthenaOfDelphi
7 years ago

  • Cc AthenaOfDelphi added

Hi,

I'm not sure whether this is the same issue, but I've just uploaded a new version (0.9) of my plugin (http://wordpress.org/extend/plugins/advanced-custom-field-widget/) but the plugin directory is not handling the latest stable version correctly.

I waited until the newest version appeared in the list in the 'Is it working' widget, but the actual latest version is not being displayed correctly or even read, appearing instead to come back as an empty string.

As a consequence, I've tried re-badging it as version 0.90 and 0.91... none of these have worked either. On my blog, the plugin does not show as needing an update so something is clearly wrong.

Could this be related to this issue?

#28 in reply to: ↑ 25 @arena
7 years ago

Replying to barry:

Replying to arena:

Hi !

don't know if it is the same issue.

when i try to download previous versions of my plugin, i get an empty folder !!

http://wordpress.org/extend/plugins/mailpress/download/

Maybe - which version(s) did you try downloading? I couldn't replicate it just now.

http://downloads.wordpress.org/plugin/mailpress.4.0.2.zip > empty folder
http://downloads.wordpress.org/plugin/mailpress.4.0.1.zip > 404
http://downloads.wordpress.org/plugin/mailpress.4.0.zip > 404

http://downloads.wordpress.org/plugin/mailpress.3.0.2.zip and following > ok

#29 @studiograsshopper
7 years ago

I'm experiencing the same intermittant problems since committing a new version of my http://wordpress.org/extend/plugins/dynamic-content-gallery-plugin/ plugin yesterday.

Clicking Download button produces 404 File Not Found errors and automatic upgrade fails in similar fashion in about 50% of cases. Several users have reported similar problems to me.

#30 @nacin
7 years ago

I reported this to Barry/Ryan last night.

#31 @ramoonus
7 years ago

  • Keywords 404 added

I think it started yesterday

#32 @scribu
7 years ago

Also seeing this while trying to update the Debug Queries plugin from a trunk install.

#33 @spacemanspud
7 years ago

Thought I would add an additional test case - my plugin is experiencing the same 404 issues as mentioned 6 weeks ago:

http://wordpress.org/extend/plugins/custom-post-archives/

Returns the most current revision(1.02) with 404 errors about 1/4 of the time. However, the trunk was updated at the same time and returns correctly every time.

Have received complaints about the automatic update not working, so symptoms are identical.

Hope that helps.

#34 @nacin
7 years ago

This is being actively investigated and fixed. We've also added some checks to ensure the sysadmins are alerted when things like this happen again.

#36 follow-up: @dd32
7 years ago

arena: Not sure if it's related, But, You've got your stable tag set to 5.0.1, which doesn't exist.

#37 in reply to: ↑ 36 @arena
7 years ago

Replying to dd32:

arena: Not sure if it's related, But, You've got your stable tag set to 5.0.1, which doesn't exist.

@dd32 not related

if i create it, i cannot download the plugin anymore

#38 in reply to: ↑ 35 @mdawaffe
7 years ago

Replying to arena:

@nacin not working for me !!!

http://downloads.wordpress.org/plugin/mailpress.4.0.2.zip > empty folder http://downloads.wordpress.org/plugin/mailpress.4.0.1.zip > 404 http://downloads.wordpress.org/plugin/mailpress.4.0.zip > 404

The latest version (5.0) works fine for me. I'm looking into the older versions.

#39 @mdawaffe
7 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

All the examples I could find return 200 now.

#40 @casben79
6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

This is apparently happening to my plugin now: http://downloads.wordpress.org/plugin/wp-slick-slider.0.7.zip

Any Idea what is causing this?

Cheers
Ben

#41 @casben79
6 years ago

  • Cc bcasey@… added

Also I noticed my plugin does not show up in any internal searches in the plugin directory.

#42 @nacin
6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to casben79:

This is apparently happening to my plugin now: http://downloads.wordpress.org/plugin/wp-slick-slider.0.7.zip

Any Idea what is causing this?

Can't reproduce. I'm finding wp-slick-slider.0.7.zip propogated to all servers.

First result on the exact text match, so it's in the system: http://wordpress.org/extend/plugins/search.php?q=WP+Slick+Slider

#43 @nacin
6 years ago

Cancel that, I'm logged in as an admin. The plugin has been disabled by another admin. I'll look into why and email you.

Note: See TracTickets for help on using tickets.