Make WordPress Core

Opened 19 years ago

Closed 18 years ago

#1516 closed defect (bug) (duplicate)

<blockquote> and <!--more-->

Reported by: jdingman's profile jdingman Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.2
Component: General Keywords: blockquote validation more bg|squashed
Focuses: Cc:

Description

Here is am example of the the bug:

<blockquote>

This is my article, but...

<!--more-->

here is more, and this breaks it.

</blockquote>

The <!--more--> inside a blockquote makes it invalid XHTML and breaks the nested <blockquote>s and divs because it thinks that the blockquote can still be continued. It doesn't close the <blockquote> tag properly when using the <!--more--> tag and this needs to be fixed so the XHTML is validated still.

Change History (3)

#1 @EvilBeAr
19 years ago

why would you place a more tag inside of a blockquote tag anyways? Of course that will break it.

#2 @coffee2code
19 years ago

  • Milestone 1.5.1 deleted

Dupe of #178

#3 @coffee2code
18 years ago

  • Keywords bg|squashed added
  • Resolution set to duplicate
  • Status changed from new to closed

As noted before, this is a duplicate of #178.

But I still contend that the ability to balance a post regardless of where the <!--more--> is inserted would be a user-friendly way of dealing with things. My patch to #178 (which I'm sure needs updating to apply to the latest code) demonstrated it is possible with minimal code changes or overhead.

However, prevailing winds suggest this may not be implemented. Reopen #178 and make your case to the dev team if you feel strongly about the matter.

Note: See TracTickets for help on using tickets.