WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#15166 closed defect (bug) (fixed)

is_plugin_active() returns based on current site in Network Admin

Reported by: kawauso Owned by:
Milestone: 3.1 Priority: normal
Severity: minor Version:
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

is_plugin_active() uses the 'active_plugins' option, which is site-specific, as well as is_plugin_active_for_network().

Most obviously affects the Plugins section in Network Admin, which displays both the current site's plugins as well as those network activated as being active.

Attachments (3)

patch.patch (577 bytes) - added by kawauso 9 years ago.
Use is_network_admin() check before using 'active_plugins' option
15166.2.diff (631 bytes) - added by kawauso 9 years ago.
Spread code over multiple lines for readability
15166.diff (857 bytes) - added by nacin 9 years ago.

Download all attachments as: .zip

Change History (7)

@kawauso
9 years ago

Use is_network_admin() check before using 'active_plugins' option

#1 @mrmist
9 years ago

  • Keywords has-patch added; is_plugin_active network plugins removed

@kawauso
9 years ago

Spread code over multiple lines for readability

#2 @nacin
9 years ago

We wouldn't put this logic into is_plugin_active. Where I would put the logic, already has the logic -- It looks like we've properly accounted for is_network_admin() in WP_Plugins_Table::display_rows(). I also can't reproduce this.

@nacin
9 years ago

#3 @nacin
9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [15870]) Add some more network admin logic to the plugins list table. fixes #15166.

#4 @nacin
9 years ago

  • Milestone changed from Awaiting Review to 3.1
Note: See TracTickets for help on using tickets.