WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15181 closed defect (bug) (worksforme)

Main blog in multisite wp 3.0 reading from wrong table

Reported by: micke021 Owned by:
Milestone: Priority: normal
Severity: critical Version:
Component: Multisite Keywords: reporter-feedback
Focuses: Cc:

Description

The main blog editor will load content from a subblog if a post or page with the same id as a post in the main blog exists in a subblog.
The call to get_post_to_edit() in wp-admin/post.php doesn't return the correct post.

A quick fix resolved the problem:
431 in post.php -> $post = get_blog_post($wpdb->blogid, $id, OBJECT, 'edit' );

Change History (2)

comment:1 westi3 years ago

  • Keywords reporter-feedback added; get_post_to_edit multisite removed

Have you tried reproducing this with no plugins enabled?

I can't reproduce it

comment:2 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.