WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15187 closed defect (bug) (duplicate)

Wordpress forces verbose page rewrite rules when posts permalink start with a static string

Reported by: Ryan_B Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Rewrite Rules Keywords:
Focuses: Cc:

Description

I have recently come to notice that while my permalink structure for posts starts with a static string the permalink is /blog/%postname% that forces the use of verbose page rewite rules, just like how using /%postname% or /$category%/%postname% would.

However use of a static string to start the posts permalink should not require verbose page permalinks to work.

I think the issue is that WordPress recognized that /%year% or some other numeric value isn't starting the permalink so it assumes that verbose page rewrite rules need to be activated.

Change History (2)

comment:1 scribu3 years ago

  • Cc scribu added

comment:2 Denis-de-Bernardy3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.