WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15188 closed defect (bug) (duplicate)

Post Slug always adds a suffix

Reported by: debashish Owned by:
Milestone: Priority: normal
Severity: major Version: 3.0.1
Component: Permalinks Keywords: Page, Slug, Permalink
Focuses: Cc:

Description

The problem I am facing is with permalinks for Pages. WordPress just won't accept the origianl slug (such as 0705), it keeps on adding -2 or -3 to it. I checked the database for the Page ID in wp_posts table. There were no other Post or page with the slug 0705.

For existing pages, on the admin console while the quick edit option on page shows the slug correctly, on full edit page the slug is again shown as 0705-3 and if I change it it doesn't change. Moreover, the permalink (say http://www.nirantar.org/0705) doesn't work not even http://www.nirantar.org/0705-3 or http://www.nirantar.org/0705-2.

I even tried deleting this page and recreating it.

With new pages if whenever I add a slug, some suffix gets added to and I am not able to get the desired slug.

Change History (4)

comment:1 follow-up: nacin3 years ago

Duplicate of #11917 -- Numeric slugs don't work, therefore we don't allow them.

comment:2 Denis-de-Bernardy3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I was about to close as dup of #11863, personally. It's the same symptoms.

comment:3 in reply to: ↑ 1 debashish3 years ago

Replying to nacin:

Duplicate of #11917 -- Numeric slugs don't work, therefore we don't allow them.

But this must be something new, my webzine has been using numeric slugs sinvce begining as I identify monthly issues in MMYY format (see http://www.nirantar.org/0405 or http://www.nirantar.org/0605). Why should newer versions of wordpress break what had been working before? I cannot change the pattern of my slugs now. Besides, when a -2 is added the slug is still practically numeric.

comment:4 debashish3 years ago

Seems #14238 is the same and has been open for months.

Note: See TracTickets for help on using tickets.