Make WordPress Core

Opened 13 years ago

Last modified 5 years ago

#15204 assigned enhancement

JavaScript Validation should trim values and set focus on invalid field

Reported by: batmoo's profile batmoo Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Taxonomy Keywords: needs-patch
Focuses: javascript Cc:

Description

If invalid fields are found after validation, focus should be placed on the first invalid field. Field values should be trimmed to check for truly empty values.

Also worth noting, the (mostly same) validateForm is located in both common.js and wpAjax.js.

Attachments (2)

15204.diff (2.2 KB) - added by batmoo 13 years ago.
15204_v2.diff (2.3 KB) - added by batmoo 13 years ago.

Download all attachments as: .zip

Change History (11)

@batmoo
13 years ago

#1 @batmoo
13 years ago

  • Keywords has-patch added
  • Owner batmoo deleted
  • Status changed from new to assigned

Patch removes redundant validateForm from common.dev.js and uses the one in wp-ajax-response.js (though, in retrospect, it may be better to move it to a more agnostic place so that non-ajax submits can make use of it too).

Patch trims field values and sets focus on the first invalid field.

#2 @nacin
13 years ago

common will probably be enqueued in more places than wp-ajax-response. I imagine it may have been intentional for both to exist.

@batmoo
13 years ago

#3 @batmoo
13 years ago

As far as I can tell, the only place that validateForm is in use is on tags.dev.js. Even then, it's redundant as almost all of the JS validation on the site is being handled by wp-ajax-response.

Regardless, new patch restores validateForm on common.dev.js, adds trim and focusing, and I've added some indentation to the functions to make them a bit more readable :)

#4 @batmoo
13 years ago

  • Keywords ux-feedback added

#5 @mdawaffe
13 years ago

  • Milestone changed from Awaiting Review to Future Release

#6 @nacin
10 years ago

  • Component changed from Validation to Taxonomy
  • Focuses javascript added
  • Milestone changed from Future Release to 3.9

#7 @bassgang
10 years ago

@batmoo can you provide more context to your description where the validation exactly happens?
Furthermore I doubt that the ticket still is a "defect (bug)", would not be "enhancement" as ticket type more appropriate?

#8 @nacin
10 years ago

  • Keywords needs-patch added; has-patch ux-feedback removed
  • Milestone changed from 3.9 to Future Release

This JS is still really dense; I'm not positive it's all fine and dandy, and given it's been three years, I doubt batmoo would know either. :-( Moving to Future, would be nice to fix this of course. Sorry for having delayed it three years ago.

#9 @chriscct7
8 years ago

  • Type changed from defect (bug) to enhancement
Note: See TracTickets for help on using tickets.