WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#15207 closed task (blessed) (fixed)

Blue theme refresh

Reported by: nacin Owned by: saracannon
Milestone: 3.1 Priority: normal
Severity: blocker Version:
Component: UI Keywords: has-patch ui-feedback
Focuses: Cc:

Description

Being headed up by the UI group.

Attachments (19)

menu-bits-vs.gif (1.4 KB) - added by saracannon 6 years ago.
ed-bg-vs.gif (444 bytes) - added by saracannon 6 years ago.
blue-grad.gif (211 bytes) - added by saracannon 6 years ago.
screen-options-right-vs.gif (178 bytes) - added by saracannon 6 years ago.
widgets-arrow-vs.gif (213 bytes) - added by saracannon 6 years ago.
15207.diff (2.0 KB) - added by PeteMall 6 years ago.
Screen options toggle sprite
15207+dashboard.diff (2.2 KB) - added by ocean90 6 years ago.
Dashboard ‹ wpHelper — WordPress.png (8.6 KB) - added by ocean90 6 years ago.
Screenshot of blue logo
wp-logo-vs.png (2.2 KB) - added by saracannon 6 years ago.
fixed the size of the png and cleaned up a bit
wp-logo-vs.2.png (2.2 KB) - added by saracannon 6 years ago.
fixed the size of the png and cleaned up a bit
blue_refresh_1.patch (3.7 KB) - added by saracannon 6 years ago.
with tweaks from the UI meeting
menu-dark-vs.gif (245 bytes) - added by saracannon 6 years ago.
bgcolor.15207.patch (569 bytes) - added by ocean90 6 years ago.
bgcolor.15207.2.patch (569 bytes) - added by ocean90 6 years ago.
15207-alternate-row.diff (362 bytes) - added by nacin 6 years ago.
Patch has the alternate color align with the background. This is the same as gray -- note the issue on Dashboard > Updates if this isn't done. Fine if we just want to remove the alternate styling on Dashboard > Updates though, if this is too light.
15207.2.diff (780 bytes) - added by PeteMall 6 years ago.
Fix colors for folded menus. Before: http://petem.in/s | After: http://petem.in/r
menu-dark-vs-rtl.gif (245 bytes) - added by saracannon 6 years ago.
RTL Menu Dark
menu-bits-rtl-vs.gif (1.5 KB) - added by saracannon 6 years ago.
RTL menu bits
rtl_blue.patch (7.6 KB) - added by saracannon 6 years ago.
Patch for light blue admin RTL

Download all attachments as: .zip

Change History (55)

#1 @saracannon
6 years ago

  • Cc sararcannon@… added

#2 @jane
6 years ago

  • Keywords needs-patch added; ui-feedback removed

Patch for new admin color scheme needs to be up by November 1st for freeze.

@saracannon
6 years ago

@saracannon
6 years ago

#3 @nacin
6 years ago

  • Owner set to saracannon
  • Status changed from new to assigned

Reviewing this today for inclusion.

#4 @nacin
6 years ago

[16144] Due to various inconsistencies.

Refresh up next.

#5 @nacin
6 years ago

(In [16145]) Blue theme refresh, first pass. props saracannon. see #15207.

#6 @nacin
6 years ago

(In [16146]) Housekeeping for blue refresh. Script bumps, image bumps, remove unused blue-specific files. see #15207.

#7 @nacin
6 years ago

(In [16147]) Remove deleted file from the manifest. Note that most other blue files were never added. see #15207.

#8 @nacin
6 years ago

What's left:

  • Screen options toggle sprite implementation. I'm attaching it to the ticket, PeteMall will be handling the patch.
  • RTL.
  • Feedback and inconsistencies that need to be addressed. UI group meets Tuesday.

#9 @nacin
6 years ago

(In [16148]) Add screen options toggle. props saracannon, see #15207.

#10 @nacin
6 years ago

Random note, it looks like we can remove visit-site-button-grad.gif and visit-site-button-grad-vs.gif. We apparently completely forgot to remove those.

@PeteMall
6 years ago

Screen options toggle sprite

#11 @PeteMall
6 years ago

  • Keywords has-patch added; needs-patch removed

#12 @ocean90
6 years ago

15207+dashboard.diff
We have a blue-grad.png in core and not a blue-grad.gif.

@ocean90
6 years ago

Screenshot of blue logo

#13 @ocean90
6 years ago

  • Keywords ui-feedback added

The size of the logos are different:

wp-logo-vs.png: 38*35
wp-logo.png: 32*32

Because of this the blue logo is cut, see screenshot.

#14 @nacin
6 years ago

(In [16152]) Implement the screen options toggle sprite across color schemes. props PeteMall, and use correct file ext, props ocean90. see #15207.

@saracannon
6 years ago

fixed the size of the png and cleaned up a bit

@saracannon
6 years ago

fixed the size of the png and cleaned up a bit

#15 @nacin
6 years ago

(In [16153]) Cleaned up WP logo for blue refresh. props saracannon, see #15207.

#16 @nacin
6 years ago

(In [16156]) New color scheme swatches for the profile page. props JohnONolan, saracannon. see #15207.

@saracannon
6 years ago

with tweaks from the UI meeting

#17 @nacin
6 years ago

(In [16173]) Blue tweaks. props saracannon, see #15207.

#18 @ocean90
6 years ago

bgcolor.15207.patch fixed the bg color of the current top menu item. http://grab.by/7n0c

@nacin
6 years ago

Patch has the alternate color align with the background. This is the same as gray -- note the issue on Dashboard > Updates if this isn't done. Fine if we just want to remove the alternate styling on Dashboard > Updates though, if this is too light.

#19 @nacin
6 years ago

Patch modifies the alternate row color a bit for the reasons mentioned above.

@PeteMall
6 years ago

Fix colors for folded menus. Before: http://petem.in/s | After: http://petem.in/r

#20 @JohnONolan
6 years ago

+1 on both ocean90's patch and PeteMall's patch

#21 @nacin
6 years ago

(In [16416]) Blue color scheme for the folded admin menu. props PeteMall, see #15207.

#22 @nacin
6 years ago

(In [16417]) Remove visit site button gradient images from pre-3.0. see #15207.

@saracannon
6 years ago

RTL Menu Dark

@saracannon
6 years ago

RTL menu bits

#23 @nacin
6 years ago

(In [16418]) Show continous color in admin menu when text wraps. props ocean90, see #15207.

#24 @nacin
6 years ago

(In [16419]) Fix the screen options sprite in RTL. Also compress and bump for previous commits. see #15207.

@saracannon
6 years ago

Patch for light blue admin RTL

#25 @nacin
6 years ago

(In [16420]) Blue theme RTL. props saracannon. see #15207.

#26 @nacin
6 years ago

(In [16421]) Don't have awkward alternate color classes for core updates on update-core. see #15207.

#27 @nacin
6 years ago

Calling this one fixed. Please open any new tickets for inconsistencies that need fixing, and reference the number here.

#28 @nacin
6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

#29 @dd32
6 years ago

(In [16796]) Remove visit site button gradient images from pre-3.0. see [16417]. see #15207.

#30 @nacin
6 years ago

(In [16876]) Use the blue background in the HTML editor, same as the visual editor. see #15207.

#31 @westi
6 years ago

  • Resolution fixed deleted
  • Severity changed from normal to blocker
  • Status changed from closed to reopened

Some of the images referenced in the blue CSS are not in svn :-(

e.g. widgets-arrow-vs.gif

#32 @westi
6 years ago

(In [17058]) Add missing file from Blue Theme refresh. See #15207.

#33 @westi
6 years ago

(In [17059]) Commit the image not the trac download page. See #15207.

#34 @westi
6 years ago

Hmm, I suck at downloading attachments from tickets :-(

#35 follow-up: @nacin
6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

I've confirmed that all other images that are referenced in colors-classic and RTL are present.

#36 in reply to: ↑ 35 @westi
6 years ago

Replying to nacin:

I've confirmed that all other images that are referenced in colors-classic and RTL are present.

Great, thanks :-)

Note: See TracTickets for help on using tickets.